summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 18:55:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 19:19:01 -0500
commit1e35abf116c5a51e20a78e99ed39b08f8bd136b0 (patch)
treea0ec8e78c30dcc9b58196238961eee0a37bacead /media-sound
parentprofiles: last-rite app-text/agrep (diff)
downloadgentoo-1e35abf116c5a51e20a78e99ed39b08f8bd136b0.tar.gz
gentoo-1e35abf116c5a51e20a78e99ed39b08f8bd136b0.tar.bz2
gentoo-1e35abf116c5a51e20a78e99ed39b08f8bd136b0.zip
media-sound/wavegain: EAPI7->8, fix build w/ upcoming clang16
Also pass -fno-strict-aliasing wrt bug #860981 Closes: https://bugs.gentoo.org/860981 Closes: https://bugs.gentoo.org/874903 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/wavegain/files/wavegain-1.3.1-clang16.patch8
-rw-r--r--media-sound/wavegain/wavegain-1.3.1-r1.ebuild (renamed from media-sound/wavegain/wavegain-1.3.1.ebuild)15
2 files changed, 16 insertions, 7 deletions
diff --git a/media-sound/wavegain/files/wavegain-1.3.1-clang16.patch b/media-sound/wavegain/files/wavegain-1.3.1-clang16.patch
new file mode 100644
index 000000000000..7b14c14a0498
--- /dev/null
+++ b/media-sound/wavegain/files/wavegain-1.3.1-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/874903
+--- a/wavegain.c
++++ b/wavegain.c
+@@ -51,2 +51,4 @@
+ #include <windows.h>
++#else
++#include <unistd.h>
+ #endif
diff --git a/media-sound/wavegain/wavegain-1.3.1.ebuild b/media-sound/wavegain/wavegain-1.3.1-r1.ebuild
index 9790a1958c4e..4af03be1334b 100644
--- a/media-sound/wavegain/wavegain-1.3.1.ebuild
+++ b/media-sound/wavegain/wavegain-1.3.1-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="ReplayGain for WAVE audio files"
-HOMEPAGE="http://www.rarewares.org/files/others/"
-SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
+HOMEPAGE="https://www.rarewares.org/files/others/"
+SRC_URI="https://www.rarewares.org/files/others/${P}srcs.zip"
+S="${WORKDIR}/WaveGain-${PV}"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -15,15 +16,15 @@ KEYWORDS="amd64 x86"
BDEPEND="app-arch/unzip"
-S="${WORKDIR}/${P/wavegain/WaveGain}"
-
PATCHES=(
"${FILESDIR}"/${PN}-1.3.1-makefile.patch
"${FILESDIR}"/${PN}-1.3.1-fno-common.patch
+ "${FILESDIR}"/${PN}-1.3.1-clang16.patch
)
src_configure() {
tc-export CC
+ append-cflags -fno-strict-aliasing #860981
}
src_install() {