summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /media-sound
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/helvum/helvum-0.4.1-r1.ebuild8
-rw-r--r--media-sound/helvum/helvum-0.5.1-r3.ebuild8
-rw-r--r--media-sound/ncspot/ncspot-1.1.2-r1.ebuild (renamed from media-sound/ncspot/ncspot-1.1.2.ebuild)5
-rw-r--r--media-sound/ncspot/ncspot-1.2.0-r1.ebuild (renamed from media-sound/ncspot/ncspot-1.2.0.ebuild)0
-rw-r--r--media-sound/ncspot/ncspot-1.2.1-r1.ebuild (renamed from media-sound/ncspot/ncspot-1.2.1.ebuild)0
-rw-r--r--media-sound/rescrobbled/rescrobbled-0.7.1-r1.ebuild (renamed from media-sound/rescrobbled/rescrobbled-0.7.1.ebuild)2
6 files changed, 18 insertions, 5 deletions
diff --git a/media-sound/helvum/helvum-0.4.1-r1.ebuild b/media-sound/helvum/helvum-0.4.1-r1.ebuild
index 62afda3e4583..4105dfcddf13 100644
--- a/media-sound/helvum/helvum-0.4.1-r1.ebuild
+++ b/media-sound/helvum/helvum-0.4.1-r1.ebuild
@@ -108,7 +108,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit cargo desktop llvm-r1 xdg
+inherit llvm-r1 cargo desktop xdg
DESCRIPTION="A GTK patchbay for pipewire"
HOMEPAGE="https://gitlab.freedesktop.org/pipewire/helvum"
@@ -131,7 +131,6 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}=
sys-devel/llvm:${LLVM_SLOT}=
- virtual/rust:0/llvm-${LLVM_SLOT}
')
virtual/pkgconfig
"
@@ -148,6 +147,11 @@ RDEPEND="${DEPEND}"
QA_FLAGS_IGNORED="usr/bin/${PN}"
+pkg_setup() {
+ llvm-r1_pkg_setup
+ rust_pkg_setup
+}
+
src_install() {
cargo_src_install
diff --git a/media-sound/helvum/helvum-0.5.1-r3.ebuild b/media-sound/helvum/helvum-0.5.1-r3.ebuild
index d43c13272c0f..c82f7a102563 100644
--- a/media-sound/helvum/helvum-0.5.1-r3.ebuild
+++ b/media-sound/helvum/helvum-0.5.1-r3.ebuild
@@ -111,7 +111,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit cargo desktop llvm-r1 xdg
+inherit llvm-r1 cargo desktop xdg
DESCRIPTION="A GTK patchbay for pipewire"
HOMEPAGE="https://gitlab.freedesktop.org/pipewire/helvum"
@@ -135,7 +135,6 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}=
sys-devel/llvm:${LLVM_SLOT}=
- virtual/rust:0/llvm-${LLVM_SLOT}
')
virtual/pkgconfig
"
@@ -153,6 +152,11 @@ RDEPEND="${DEPEND}"
QA_FLAGS_IGNORED="usr/bin/${PN}"
+pkg_setup() {
+ llvm-r1_pkg_setup
+ rust_pkg_setup
+}
+
src_install() {
cargo_src_install
diff --git a/media-sound/ncspot/ncspot-1.1.2.ebuild b/media-sound/ncspot/ncspot-1.1.2-r1.ebuild
index a860b34aca6b..35a515a6839f 100644
--- a/media-sound/ncspot/ncspot-1.1.2.ebuild
+++ b/media-sound/ncspot/ncspot-1.1.2-r1.ebuild
@@ -533,6 +533,11 @@ BDEPEND="${PYTHON_DEPS}
QA_FLAGS_IGNORED="/usr/bin/ncspot"
+pkg_setup() {
+ python-any-r1_pkg_setup
+ rust_pkg_setup
+}
+
src_configure() {
local myfeaturesdef=""
diff --git a/media-sound/ncspot/ncspot-1.2.0.ebuild b/media-sound/ncspot/ncspot-1.2.0-r1.ebuild
index f461b2a76eb4..f461b2a76eb4 100644
--- a/media-sound/ncspot/ncspot-1.2.0.ebuild
+++ b/media-sound/ncspot/ncspot-1.2.0-r1.ebuild
diff --git a/media-sound/ncspot/ncspot-1.2.1.ebuild b/media-sound/ncspot/ncspot-1.2.1-r1.ebuild
index ce56d901f746..ce56d901f746 100644
--- a/media-sound/ncspot/ncspot-1.2.1.ebuild
+++ b/media-sound/ncspot/ncspot-1.2.1-r1.ebuild
diff --git a/media-sound/rescrobbled/rescrobbled-0.7.1.ebuild b/media-sound/rescrobbled/rescrobbled-0.7.1-r1.ebuild
index 690a968b2706..2330b9732ea7 100644
--- a/media-sound/rescrobbled/rescrobbled-0.7.1.ebuild
+++ b/media-sound/rescrobbled/rescrobbled-0.7.1-r1.ebuild
@@ -128,7 +128,7 @@ inherit cargo systemd
DESCRIPTION="MPRIS music scrobbler daemon"
HOMEPAGE="https://github.com/InputUsername/rescrobbled"
SRC_URI="https://github.com/InputUsername/rescrobbled/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris)"
+ ${CARGO_CRATE_URIS}"
LICENSE="GPL-3"
# Dependent crate licenses