summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/vlevel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/vlevel')
-rw-r--r--media-sound/vlevel/Manifest1
-rw-r--r--media-sound/vlevel/files/vlevel-0.5-makefile.patch26
-rw-r--r--media-sound/vlevel/metadata.xml8
-rw-r--r--media-sound/vlevel/vlevel-0.5-r1.ebuild39
4 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/vlevel/Manifest b/media-sound/vlevel/Manifest
new file mode 100644
index 000000000000..82cbd731282d
--- /dev/null
+++ b/media-sound/vlevel/Manifest
@@ -0,0 +1 @@
+DIST vlevel-0.5.tar.gz 25873 SHA256 50322c5bb8942aa3a3cf8a65e83d96b8ef3ecdaedb4dabbaa3f912601df09d10
diff --git a/media-sound/vlevel/files/vlevel-0.5-makefile.patch b/media-sound/vlevel/files/vlevel-0.5-makefile.patch
new file mode 100644
index 000000000000..af50f1e3c08c
--- /dev/null
+++ b/media-sound/vlevel/files/vlevel-0.5-makefile.patch
@@ -0,0 +1,26 @@
+--- vlevel-0.5/Makefile.orig
++++ vlevel-0.5/Makefile
+@@ -30,6 +30,7 @@
+ all: vlevel-bin vlevel-ladspa.so
+
+ install: all
++ mkdir -p $(PREFIX)
+ cp -f vlevel-bin $(PREFIX)
+ mkdir -p $(LADSPA_PREFIX)
+ cp -f vlevel-ladspa.so $(LADSPA_PREFIX)
+@@ -38,13 +39,13 @@
+ rm -f *.o vlevel-bin vlevel-ladspa.so
+
+ vlevel-ladspa.so: vlevel-ladspa.o volumeleveler.o
+- $(CXX) $(CXXFLAGS) -shared -o vlevel-ladspa.so vlevel-ladspa.o volumeleveler.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared -o vlevel-ladspa.so vlevel-ladspa.o volumeleveler.o
+
+ vlevel-ladspa.o: vlevel-ladspa.cpp volumeleveler.h vlevel-ladspa.h vlevel.h ladspa.h
+ $(CXX) $(CXXFLAGS) -c vlevel-ladspa.cpp
+
+ vlevel-bin: volumeleveler.o commandline.o vlevel-bin.o vlevel.h
+- $(CXX) $(CXXFLAGS) -o vlevel-bin vlevel-bin.o volumeleveler.o commandline.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o vlevel-bin vlevel-bin.o volumeleveler.o commandline.o
+
+ volumeleveler.o: volumeleveler.cpp volumeleveler.h vlevel.h
+ $(CXX) $(CXXFLAGS) -c volumeleveler.cpp
diff --git a/media-sound/vlevel/metadata.xml b/media-sound/vlevel/metadata.xml
new file mode 100644
index 000000000000..c599f7d93efd
--- /dev/null
+++ b/media-sound/vlevel/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">vlevel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/vlevel/vlevel-0.5-r1.ebuild b/media-sound/vlevel/vlevel-0.5-r1.ebuild
new file mode 100644
index 000000000000..7dbe8468272c
--- /dev/null
+++ b/media-sound/vlevel/vlevel-0.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Dynamic compressor to amplify quiet parts of music"
+HOMEPAGE="http://vlevel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vlevel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="media-libs/ladspa-sdk"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX) CXXFLAGS="$CXXFLAGS -fPIC -DPIC"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr/bin/" LADSPA_PREFIX="${D}/usr/$(get_libdir)/ladspa/" install
+
+ dodoc README TODO docs/*
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe utils/{levelplay,raw2wav,vlevel-dir}
+ docinto examples
+ dodoc utils/README
+ docompress -x /usr/share/doc/${PF}/examples/{levelplay,raw2wav,vlevel-dir}
+}