summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-03 20:26:27 +0400
committerSam James <sam@gentoo.org>2024-05-09 01:52:15 +0100
commitf552921529ee830d7e2ea1b4f2e03c8327c9d41a (patch)
tree26aa184bee3f4ab9e93bafce6eacc70ae691a33c /media-sound/streamripper
parentmedia-libs/audiofile: restore keywords (diff)
downloadgentoo-f552921529ee830d7e2ea1b4f2e03c8327c9d41a.tar.gz
gentoo-f552921529ee830d7e2ea1b4f2e03c8327c9d41a.tar.bz2
gentoo-f552921529ee830d7e2ea1b4f2e03c8327c9d41a.zip
media-sound/streamripper: Fix includes and wrongly named C99 types
[sam: Scrub patch, add bug refs, fix SRC_URI.] Closes: https://bugs.gentoo.org/713314 Closes: https://bugs.gentoo.org/896432 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36079 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/streamripper')
-rw-r--r--media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch44
-rw-r--r--media-sound/streamripper/streamripper-1.64.6-r1.ebuild45
2 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch b/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch
new file mode 100644
index 000000000000..60fb15da9433
--- /dev/null
+++ b/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch
@@ -0,0 +1,44 @@
+We live in modern world and have ANSI C here. Plus, nothing defines ANSI_PROTOTYPES
+Include unconditionally
+
+Closes: https://bugs.gentoo.org/713314
+Closes: https://bugs.gentoo.org/896432
+--- a/lib/argv.c
++++ b/lib/argv.c
+@@ -52,25 +52,10 @@
+
+ /* Routines imported from standard C runtime libraries. */
+
+-#ifdef ANSI_PROTOTYPES
+-
+ #include <stddef.h>
+ #include <string.h>
+ #include <stdlib.h>
+
+-#else /* !ANSI_PROTOTYPES */
+-
+-#if !defined _WIN32 || defined __GNUC__
+-extern char *memcpy (); /* Copy memory region */
+-extern int strlen (); /* Count length of string */
+-extern char *malloc (); /* Standard memory allocater */
+-extern char *realloc (); /* Standard memory reallocator */
+-extern void free (); /* Free malloc'd memory */
+-extern char *strdup (); /* Duplicate a string */
+-#endif
+-
+-#endif /* ANSI_PROTOTYPES */
+-
+
+ #ifndef NULL
+ #define NULL 0
+--- a/lib/ripstream.c
++++ b/lib/ripstream.c
+@@ -714,7 +714,7 @@
+ char bigbuf[HEADER_SIZE] = "";
+ ID3V2frame id3v2frame;
+ #ifndef WIN32
+- __uint32_t framesize = 0;
++ uint32_t framesize = 0;
+ #else
+ unsigned long int framesize = 0;
+ #endif
diff --git a/media-sound/streamripper/streamripper-1.64.6-r1.ebuild b/media-sound/streamripper/streamripper-1.64.6-r1.ebuild
new file mode 100644
index 000000000000..1efacf79082f
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="https://streamripper.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="vorbis"
+
+RDEPEND="
+ media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-autotools.patch
+ "${FILESDIR}"/${P}-fix-c99.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ default
+ dodoc parse_rules.txt
+}