summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-04 22:32:01 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-04 22:32:01 +0200
commit760917faa46ea5b40249680cbfd4031760ff0414 (patch)
treec272ba422647f0f1a8cade9f0e7e1836f223be6e /media-sound/scream
parentmedia-sound/scream: add 3.7 (diff)
downloadgentoo-760917faa46ea5b40249680cbfd4031760ff0414.tar.gz
gentoo-760917faa46ea5b40249680cbfd4031760ff0414.tar.bz2
gentoo-760917faa46ea5b40249680cbfd4031760ff0414.zip
media-sound/scream: sync live ebuild
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/scream')
-rw-r--r--media-sound/scream/scream-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-sound/scream/scream-9999.ebuild b/media-sound/scream/scream-9999.ebuild
index 1c3ead36e4d3..019926a23b77 100644
--- a/media-sound/scream/scream-9999.ebuild
+++ b/media-sound/scream/scream-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,8 +7,9 @@ inherit cmake
DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
HOMEPAGE="https://github.com/duncanthrax/scream"
+S="${WORKDIR}/${P}/Receivers/unix"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
else
@@ -16,24 +17,25 @@ else
KEYWORDS="~amd64"
fi
-S="${WORKDIR}/${P}/Receivers/unix"
-
LICENSE="Ms-PL"
SLOT="0"
-IUSE="alsa pulseaudio"
+IUSE="alsa jack pulseaudio"
RDEPEND="
alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )
-"
+ jack? (
+ media-libs/soxr
+ virtual/jack
+ )
+ pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
local mycmakeargs=(
-DALSA_ENABLE=$(usex alsa)
+ -DJACK_ENABLE=$(usex jack)
-DPULSEAUDIO_ENABLE=$(usex pulseaudio)
)
-
cmake_src_configure
}