summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/picard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/Manifest2
-rw-r--r--media-sound/picard/metadata.xml12
-rw-r--r--media-sound/picard/picard-1.3.1.ebuild49
-rw-r--r--media-sound/picard/picard-1.3.2-r1.ebuild50
4 files changed, 113 insertions, 0 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
new file mode 100644
index 000000000000..22485336fe3c
--- /dev/null
+++ b/media-sound/picard/Manifest
@@ -0,0 +1,2 @@
+DIST picard-1.3.1.tar.gz 2047677 SHA256 f83ec4ab703134a3dbd8203a2b30c15ea87bec79c02446506e4dce1ec87f7d02 SHA512 72641e1f604cc3db339400511e1b37ce513f315e200af3ed25dd842cfa32b8b0a3b93cf60cd01b565be49f95931e7da36742efeb45a4619351acbe70edb511c5 WHIRLPOOL ace3cb441038e09888a2985e2f23149bcaa665d311a2bbd583648e17aeee4453168fc5e9df68b8fcd6acf772e1e4b4e33329643cb840f3355b2a1f420763bcb1
+DIST picard-1.3.2.tar.gz 2047760 SHA256 e728234560b82eb33d3143a53d3bbb92833455fd130f8d2083193cffceea4120 SHA512 d5613dd0b29f67a754a9449c6ebb29e4f7a519137dbcd29b03e64678ba49c75542573487c1f95047c0ab43630794fd92365a46dc9820347ffd2eae5a04e531be WHIRLPOOL 5c3cbd5860162ede0150f7e680d7732f38c875e5475fb16dfac2f6f7d51979678567fe677a2887197db963fdf1a75f1ba4f45d132e9fc0923a2d726ffe30a019
diff --git a/media-sound/picard/metadata.xml b/media-sound/picard/metadata.xml
new file mode 100644
index 000000000000..cce6e75146f7
--- /dev/null
+++ b/media-sound/picard/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>MusicBrainz Picard is a cross-platform MusicBrainz tag editor
+ written in Python. Picard Tagger is intended to be the next generation of
+ tagger for MusicBrainz, with a focus on album oriented tagging as opposed to
+ track based tagging and cross platform compatibility.</longdescription>
+<use>
+ <flag name='acoustid'>Use media-libs/chromaprint for acoustic fingerprinting</flag>
+</use>
+</pkgmetadata>
diff --git a/media-sound/picard/picard-1.3.1.ebuild b/media-sound/picard/picard-1.3.1.ebuild
new file mode 100644
index 000000000000..23c4bb7731ae
--- /dev/null
+++ b/media-sound/picard/picard-1.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+inherit eutils distutils-r1 readme.gentoo
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="http://picard.musicbrainz.org/"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+acoustid +cdda nls"
+
+DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ media-libs/mutagen
+ acoustid? ( >=media-libs/chromaprint-1.0[tools] )
+ cdda? ( >=media-libs/libdiscid-0.1.1 )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" # doesn't work with ebuilds
+S=${WORKDIR}/${PN}-release-${PV}
+DOCS="AUTHORS.txt NEWS.txt"
+
+DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+ firefox '%s' &
+to let python know which browser to use."
+
+src_compile() {
+ distutils-r1_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils-r1_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+ readme.gentoo_create_doc
+}
diff --git a/media-sound/picard/picard-1.3.2-r1.ebuild b/media-sound/picard/picard-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..7a8a330b8acf
--- /dev/null
+++ b/media-sound/picard/picard-1.3.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+inherit eutils distutils-r1 readme.gentoo
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="http://picard.musicbrainz.org/"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acoustid +cdda nls"
+
+DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ dev-qt/qtgui:4[accessibility]
+ media-libs/mutagen
+ acoustid? ( >=media-libs/chromaprint-1.0[tools] )
+ cdda? ( dev-python/python-discid )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" # doesn't work with ebuilds
+S=${WORKDIR}/${PN}-release-${PV}
+DOCS="AUTHORS.txt NEWS.txt"
+
+DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+ firefox '%s' &
+to let python know which browser to use."
+
+src_compile() {
+ distutils-r1_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils-r1_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+ readme.gentoo_create_doc
+}