summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/multimux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/multimux')
-rw-r--r--media-sound/multimux/Manifest1
-rw-r--r--media-sound/multimux/files/multimux-0.2.4-makefiles.patch13
-rw-r--r--media-sound/multimux/metadata.xml5
-rw-r--r--media-sound/multimux/multimux-0.2.5.2.ebuild31
4 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/multimux/Manifest b/media-sound/multimux/Manifest
new file mode 100644
index 000000000000..f5181a6a537d
--- /dev/null
+++ b/media-sound/multimux/Manifest
@@ -0,0 +1 @@
+DIST multimux-0.2.5.2.tgz 16855 SHA256 78217012abf7944729bd8e4c471323349f26cc9b77b6afbd99170e04af7d53cb
diff --git a/media-sound/multimux/files/multimux-0.2.4-makefiles.patch b/media-sound/multimux/files/multimux-0.2.4-makefiles.patch
new file mode 100644
index 000000000000..61ab8b8b395c
--- /dev/null
+++ b/media-sound/multimux/files/multimux-0.2.4-makefiles.patch
@@ -0,0 +1,13 @@
+Index: multimux-0.2.4/Makefile
+===================================================================
+--- multimux-0.2.4.orig/Makefile
++++ multimux-0.2.4/Makefile
+@@ -17,7 +17,7 @@ multimux.o
+ all:
+ $(CC) $(CFLAGS) -c $(SRC1)
+
+- $(CC) -o multimux $(OBJECT1) $(LIBRARY)
++ $(CC) $(LDFLAGS) -o multimux $(OBJECT1) $(LIBRARY)
+
+ # DEPENDENCIES
+ multimux.o : multimux.c multimux.h
diff --git a/media-sound/multimux/metadata.xml b/media-sound/multimux/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/multimux/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/multimux/multimux-0.2.5.2.ebuild b/media-sound/multimux/multimux-0.2.5.2.ebuild
new file mode 100644
index 000000000000..5dc0d4268f65
--- /dev/null
+++ b/media-sound/multimux/multimux-0.2.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="combines up to 8 audio mono wave ch. into one big multi ch. wave file"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.2.4-makefiles.patch"
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin multimux
+ dodoc CHANGES README
+}