summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-06 13:16:50 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-06 13:22:56 +0100
commit796bcc7cd8d6c7ecc7a537d13da01484c9c5d459 (patch)
treeaaa349ce984430a4a3c6325dce1ff07cf7ceb114 /media-sound/guayadeque
parentapp-misc/tasque: Remove linguas_* from IUSE. (diff)
downloadgentoo-796bcc7cd8d6c7ecc7a537d13da01484c9c5d459.tar.gz
gentoo-796bcc7cd8d6c7ecc7a537d13da01484c9c5d459.tar.bz2
gentoo-796bcc7cd8d6c7ecc7a537d13da01484c9c5d459.zip
media-sound/guayadeque: Remove linguas_* from IUSE.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/guayadeque')
-rw-r--r--media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild8
-rw-r--r--media-sound/guayadeque/guayadeque-9999.ebuild8
2 files changed, 4 insertions, 12 deletions
diff --git a/media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild b/media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild
index a35520325583..53d52ddcc332 100644
--- a/media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild
+++ b/media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,10 +50,6 @@ DEPEND="${RDEPEND}
# echo $(cat po/CMakeLists.txt | grep ADD_SUBDIRECTORY | sed 's#ADD_SUBDIRECTORY( \(\w\+\) )#\1#')
LANGS=( bg ca_ES cs de el es fr hr hu is it ja nb nl pl pt pt_BR ru sk sr sr@latin sv th tr uk )
-for l in "${LANGS[@]}"; do
- IUSE+=" linguas_${l}"
-done
-unset l
pkg_setup() {
setup-wxwidgets
@@ -69,7 +65,7 @@ src_prepare() {
cd po || die
local l
for l in "${LANGS[@]}"; do
- ! use linguas_${l} && cmake_comment_add_subdirectory ${l}
+ ! has ${l} ${LINGUAS-${l}} && cmake_comment_add_subdirectory ${l}
done
}
diff --git a/media-sound/guayadeque/guayadeque-9999.ebuild b/media-sound/guayadeque/guayadeque-9999.ebuild
index 92382fa215d8..992be8f8b790 100644
--- a/media-sound/guayadeque/guayadeque-9999.ebuild
+++ b/media-sound/guayadeque/guayadeque-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -61,10 +61,6 @@ DEPEND="${RDEPEND}
# echo $(cat po/CMakeLists.txt | grep ADD_SUBDIRECTORY | sed 's#ADD_SUBDIRECTORY( \(\w\+\) )#\1#')
LANGS=( bg ca_ES cs de el es fr hr hu is it ja nb nl pl pt pt_BR ru sk sr sr@latin sv th tr uk )
-for l in "${LANGS[@]}"; do
- IUSE+=" linguas_${l}"
-done
-unset l
pkg_setup() {
setup-wxwidgets
@@ -88,7 +84,7 @@ src_prepare() {
cd po || die
local l
for l in "${LANGS[@]}"; do
- ! use linguas_${l} && cmake_comment_add_subdirectory ${l}
+ ! has ${l} ${LINGUAS-${l}} && cmake_comment_add_subdirectory ${l}
done
}