summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-13 21:25:54 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:55:07 +0200
commit744f9162044409814d5c477ca422276cf82ca889 (patch)
tree4d1d889dc469700335912058da3ce4cbd32efb5e /media-sound/gnump3d
parentnet-proxy/redsocks: drop old version (diff)
downloadgentoo-744f9162044409814d5c477ca422276cf82ca889.tar.gz
gentoo-744f9162044409814d5c477ca422276cf82ca889.tar.bz2
gentoo-744f9162044409814d5c477ca422276cf82ca889.zip
media-sound/gnump3d: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781332 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r3.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/gnump3d/gnump3d-3.0-r3.ebuild b/media-sound/gnump3d/gnump3d-3.0-r3.ebuild
new file mode 100644
index 000000000000..67661e9529e0
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib perl-module
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="https://www.gnu.org/software/gnump3d/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ppc64 sparc x86"
+IUSE="sox"
+
+DEPEND="
+ acct-group/gnump3d
+ acct-user/gnump3d
+"
+
+RDEPEND="
+ ${DEPEND}
+ sox? ( media-sound/sox )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ perl_set_version
+
+ insinto "${VENDOR_LIB}"/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ sed -e "s,PLUGINDIR,${VENDOR_LIB},g" -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+ sed -e 's,^user *= *\(.*\)$,user = gnump3d,g' -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ keepdir /var/cache/gnump3d/serving
+
+ fowners gnump3d:gnump3d /var/log/gnump3d /var/cache/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}