summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-15 17:32:37 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-15 18:29:46 +0100
commit68c63adbecc153c4527908360a18368ae6a03472 (patch)
treeedc2559b3e750f75ff1a02049a151c361a5de3a0 /media-sound/gnome-music
parentgnome-base/gsettings-desktop-schemas: Fix IncorrectCopyright warning (diff)
downloadgentoo-68c63adbecc153c4527908360a18368ae6a03472.tar.gz
gentoo-68c63adbecc153c4527908360a18368ae6a03472.tar.bz2
gentoo-68c63adbecc153c4527908360a18368ae6a03472.zip
media-sound/gnome-music: add 47.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/38668
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest1
-rw-r--r--media-sound/gnome-music/gnome-music-47.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 35da8fc2e0b3..ae8f347d07d1 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1,3 +1,4 @@
DIST gnome-music-45.1.tar.xz 1666152 BLAKE2B 27403070735003df5d907fae2675b67f5b907e10e55e2ed3b31e369e146c03a2d7c95371092043862d83968fc45131ddb7643e34634b0a98d686402fdf676118 SHA512 6cc123eda769d524e5c215c7167248b15ac21fd99a1ac385069c8bac8a03652d458460438adec5853daf329f61d70339f5765b938badc862151b655ba64a80cf
DIST gnome-music-46.0.tar.xz 1667376 BLAKE2B b8eff0b4b1815af7e29b09be066f2415b1c41fb7724564d7724aefc8804b51ed1f26022f3b5d2d4be640980ddb2446f557a6861b57a020ff119aadb1b37e9809 SHA512 f0fc16029c9e7dc2f9824604ac81b5c3d6f4165878f8558e6a1372ae1a6188d9bfc100f658897a37db7f1250d6b3c50154aee75225d3bb333749fa3176751b14
DIST gnome-music-46.1.tar.xz 1672556 BLAKE2B 64c1103489e67076ab1e4c751a7da72c476a01cff0a5a88f172e18d24aaf9e4ce97b78cf47582098f3021101d94e7ed3fbb97afa515b9dddb8678711a51a3c22 SHA512 e54029cbc08bb6565ae0b44263e5dc25956687b41fa9e6cd3b617adbfb4f46f7296b297ab4febf788b2c31107522a200e8f1ff9ed73e0fee04ec0b2bc3bbe293
+DIST gnome-music-47.1.tar.xz 1673688 BLAKE2B 63b2793a0b38eb57cf71b7b731745724bada55885d09b038de9490abf00b1369527b5f552067bb5ed12c802f8de3905cf460e4d885f88759a3a85d8969e6d015 SHA512 2f5b8e47bdb5c4840c367cde537a93012118bda3848b3098d617079e34bf9bdf161a50f687cd23aacfb4b0d6b64fcdff8d21911765b96aabfc298e492c0db064
diff --git a/media-sound/gnome-music/gnome-music-47.1.ebuild b/media-sound/gnome-music/gnome-music-47.1.ebuild
new file mode 100644
index 000000000000..46aaf1591555
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-47.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://apps.gnome.org/Music/ https://gitlab.gnome.org/GNOME/gnome-music/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.67.1:2
+ >=dev-libs/gobject-introspection-1.54:=
+ >=gui-libs/gtk-4.10.0:4[introspection]
+ >=gui-libs/libadwaita-1.5_beta:1=[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:3.0[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.47.0:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.15-r1:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.16:0.3[tracker]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}