summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-13 10:13:48 +0000
committerSam James <sam@gentoo.org>2023-01-13 10:17:36 +0000
commita3634bca07cf0209ddaed3c88f9ddc06af60046b (patch)
tree95dff77400ad479f357772a78b02b9f66e26ba1f /media-sound/beets
parentmedia-libs/mutagen: fix build w/ sphinx 6 (diff)
downloadgentoo-a3634bca07cf0209ddaed3c88f9ddc06af60046b.tar.gz
gentoo-a3634bca07cf0209ddaed3c88f9ddc06af60046b.tar.bz2
gentoo-a3634bca07cf0209ddaed3c88f9ddc06af60046b.zip
media-sound/beets: fix build w/ sphinx 6
Closes: https://bugs.gentoo.org/889460 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/beets')
-rw-r--r--media-sound/beets/beets-1.6.0.ebuild3
-rw-r--r--media-sound/beets/files/1.6.0-sphinx-6.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/media-sound/beets/beets-1.6.0.ebuild b/media-sound/beets/beets-1.6.0.ebuild
index 4550e6da0e11..e4ae0a196374 100644
--- a/media-sound/beets/beets-1.6.0.ebuild
+++ b/media-sound/beets/beets-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -84,6 +84,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PV}-0001-Remove-test_completion.patch"
+ "${FILESDIR}/${PV}-sphinx-6.patch"
)
DOCS=( README.rst docs/changelog.rst )
diff --git a/media-sound/beets/files/1.6.0-sphinx-6.patch b/media-sound/beets/files/1.6.0-sphinx-6.patch
new file mode 100644
index 000000000000..d946e93b76b8
--- /dev/null
+++ b/media-sound/beets/files/1.6.0-sphinx-6.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/889460
+https://github.com/beetbox/beets/commit/2106f471affd1dab35b4b26187b9c74d034528c5
+
+From 2106f471affd1dab35b4b26187b9c74d034528c5 Mon Sep 17 00:00:00 2001
+From: Jack Wilsdon <jack.wilsdon@gmail.com>
+Date: Sat, 31 Dec 2022 14:23:34 +0000
+Subject: [PATCH] Add missing placeholders to extlinks captions
+
+Sphinx 6.0.0 changed extlinks to always require placeholders in link
+captions. See https://github.com/sphinx-doc/sphinx/commit/93cf1a57d916a1ff96c8e8a0356d0256e40489ac
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -18,10 +18,10 @@
+
+ # External links to the bug tracker and other sites.
+ extlinks = {
+- 'bug': ('https://github.com/beetbox/beets/issues/%s', '#'),
+- 'user': ('https://github.com/%s', ''),
+- 'pypi': ('https://pypi.org/project/%s/', ''),
+- 'stdlib': ('https://docs.python.org/3/library/%s.html', ''),
++ 'bug': ('https://github.com/beetbox/beets/issues/%s', '#%s'),
++ 'user': ('https://github.com/%s', '%s'),
++ 'pypi': ('https://pypi.org/project/%s/', '%s'),
++ 'stdlib': ('https://docs.python.org/3/library/%s.html', '%s'),
+ }
+
+ linkcheck_ignore = [
+