summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-06-15 07:10:16 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-06-15 07:10:16 +0200
commitc2e62325c1cc85dc35c3fc49c9fe6b060881fbc2 (patch)
treefdab4740755c2324578cdcdc43f36f12723dbd24 /media-radio
parentdev-libs/libgit2: Stabilize 1.8.1 arm64, #934326 (diff)
downloadgentoo-c2e62325c1cc85dc35c3fc49c9fe6b060881fbc2.tar.gz
gentoo-c2e62325c1cc85dc35c3fc49c9fe6b060881fbc2.tar.bz2
gentoo-c2e62325c1cc85dc35c3fc49c9fe6b060881fbc2.zip
media-radio/wsjtx: Fix missing variable declaration
Closes: https://bugs.gentoo.org/934307 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/wsjtx/files/wsjtx-2.7.0_rc4-fix_NFFT.patch13
-rw-r--r--media-radio/wsjtx/wsjtx-2.7.0_rc4.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/media-radio/wsjtx/files/wsjtx-2.7.0_rc4-fix_NFFT.patch b/media-radio/wsjtx/files/wsjtx-2.7.0_rc4-fix_NFFT.patch
new file mode 100644
index 000000000000..83b3c779de26
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-2.7.0_rc4-fix_NFFT.patch
@@ -0,0 +1,13 @@
+# See https://sourceforge.net/p/wsjt/mailman/message/58778025/
+diff --git a/qmap/libqmap/decode0.f90 b/qmap/libqmap/decode0.f90
+index 55a58dc..ed58cd2 100755
+--- a/qmap/libqmap/decode0.f90
++++ b/qmap/libqmap/decode0.f90
+@@ -2,6 +2,7 @@ subroutine decode0(dd,ss,savg)
+
+ use timer_module, only: timer
+ parameter (NSMAX=60*96000)
++ parameter (NFFT=32768)
+
+ real*4 dd(2,NSMAX),ss(400,NFFT),savg(NFFT)
+ real*8 fcenter
diff --git a/media-radio/wsjtx/wsjtx-2.7.0_rc4.ebuild b/media-radio/wsjtx/wsjtx-2.7.0_rc4.ebuild
index 19392764677e..12a363f40cbf 100644
--- a/media-radio/wsjtx/wsjtx-2.7.0_rc4.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.7.0_rc4.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.2.0-werror.patch"
"${FILESDIR}/${PN}-2.3.0-drop-docs.patch"
"${FILESDIR}/${PN}-clang.patch"
+ "${FILESDIR}/${P}-fix_NFFT.patch"
)
DOCS=( AUTHORS BUGS NEWS README THANKS )