summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-08-12 10:09:01 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-08-16 09:33:11 +0300
commit09590fea4a59deb0d456a2ffe12c261bfa0169f3 (patch)
treec741116f6e37cc30dd8539d1b23d0e33b14c3df8 /media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild
parentdev-python/jc: remove redundant sed, update HOMEPAGE (diff)
downloadgentoo-09590fea4a59deb0d456a2ffe12c261bfa0169f3.tar.gz
gentoo-09590fea4a59deb0d456a2ffe12c261bfa0169f3.tar.bz2
gentoo-09590fea4a59deb0d456a2ffe12c261bfa0169f3.zip
media-plugins/vdr-osdteletext: version bump to 2.2.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/21957 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild')
-rw-r--r--media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild b/media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild
new file mode 100644
index 000000000000..c3c5b5559223
--- /dev/null
+++ b/media-plugins/vdr-osdteletext/vdr-osdteletext-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user-info vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Osd-Teletext displays the teletext/videotext on the OSD"
+HOMEPAGE="https://projects.vdr-developer.org/projects/plg-osdteletext https://github.com/vdr-projects/vdr-plugin-osdteletext/"
+SRC_URI="https://github.com/vdr-projects/vdr-plugin-osdteletext/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/vdr-plugin-osdteletext-${PV}"
+
+LICENSE="GPL-2+ public-domain" #teletext2.ttf, not copyrightable
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-video/vdr"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-.*
+ usr/lib64/vdr/plugins/libvdr-.*"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/sudoers.d
+ insopts -m440
+ newins "${FILESDIR}/vdr-osdteletext.sudo" vdr-osdteletext
+
+ local vdr_user_home=$(egethome vdr)
+ insinto "${vdr_user_home}/.local/share/fonts/"
+ insopts -m444
+ doins teletext2.ttf
+ fowners -R vdr:vdr "${vdr_user_home}/.local"
+}
+
+pkg_postinst() {
+ elog "This ebuild has installed a special teletext font"
+ elog "named \"teletext2\""
+ elog "You may go to the plugin's setup menu and select"
+ elog "the font."
+}