summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-bgprocess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-bgprocess')
-rw-r--r--media-plugins/vdr-bgprocess/Manifest1
-rw-r--r--media-plugins/vdr-bgprocess/files/vdr-bgprocess-0.1.0-fix-i18n.diff14
-rw-r--r--media-plugins/vdr-bgprocess/metadata.xml10
-rw-r--r--media-plugins/vdr-bgprocess/vdr-bgprocess-0.1.0.ebuild21
4 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/vdr-bgprocess/Manifest b/media-plugins/vdr-bgprocess/Manifest
new file mode 100644
index 000000000000..1a2ab5f5185c
--- /dev/null
+++ b/media-plugins/vdr-bgprocess/Manifest
@@ -0,0 +1 @@
+DIST vdr-bgprocess-0.1.0.tgz 16454 RMD160 fa18fa014f2b65ffb78af439c9a03daf03ef3abb SHA1 fcccc7259ab0fe87e19faf7cf2c7892455361ad6 SHA256 79612020bda0cf59265ceea9898a3a73179ee8caed44fbb9b259d0e52f7fa91f
diff --git a/media-plugins/vdr-bgprocess/files/vdr-bgprocess-0.1.0-fix-i18n.diff b/media-plugins/vdr-bgprocess/files/vdr-bgprocess-0.1.0-fix-i18n.diff
new file mode 100644
index 000000000000..cb7b3bf37b76
--- /dev/null
+++ b/media-plugins/vdr-bgprocess/files/vdr-bgprocess-0.1.0-fix-i18n.diff
@@ -0,0 +1,14 @@
+Index: bgprocess-0.1.0/bgprocess.c
+===================================================================
+--- bgprocess-0.1.0.orig/bgprocess.c
++++ bgprocess-0.1.0/bgprocess.c
+@@ -152,7 +152,9 @@ bool cPluginBgprocess::ProcessArgs(int a
+ bool cPluginBgprocess::Initialize(void)
+ {
+ // Initialize any background activities the plugin shall perform.
++#if VDRVERSNUM < 10507
+ RegisterI18n(tlPhrases);
++#endif
+ return true;
+ }
+
diff --git a/media-plugins/vdr-bgprocess/metadata.xml b/media-plugins/vdr-bgprocess/metadata.xml
new file mode 100644
index 000000000000..1d6580fca7dd
--- /dev/null
+++ b/media-plugins/vdr-bgprocess/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-bgprocess/vdr-bgprocess-0.1.0.ebuild b/media-plugins/vdr-bgprocess/vdr-bgprocess-0.1.0.ebuild
new file mode 100644
index 000000000000..3ad44f86070a
--- /dev/null
+++ b/media-plugins/vdr-bgprocess/vdr-bgprocess-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Collect information about background process status"
+HOMEPAGE="http://linuxtv.org/pipermail/vdr/2008-July/017245.html"
+SRC_URI="http://www.reelbox.org/software/vdr/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}-fix-i18n.diff")