summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-07-29 12:04:54 -0400
committerCraig Andrews <candrews@gentoo.org>2020-07-29 14:10:48 -0400
commit19be72e774bbcf54738f3b2e526367da1bcea360 (patch)
treecc3be841a12e84e5410843ba49bdbb98d644c8fe /media-plugins/kodi-pvr-hts
parentmedia-plugins/kodi-pvr-filmon: 5.1.0 version bump (diff)
downloadgentoo-19be72e774bbcf54738f3b2e526367da1bcea360.tar.gz
gentoo-19be72e774bbcf54738f3b2e526367da1bcea360.tar.bz2
gentoo-19be72e774bbcf54738f3b2e526367da1bcea360.zip
media-plugins/kodi-pvr-hts: 7.1.1 version bump
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-hts')
-rw-r--r--media-plugins/kodi-pvr-hts/Manifest1
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.1.1.ebuild34
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/media-plugins/kodi-pvr-hts/Manifest b/media-plugins/kodi-pvr-hts/Manifest
index 1f4857dfc96a..3b07223902a3 100644
--- a/media-plugins/kodi-pvr-hts/Manifest
+++ b/media-plugins/kodi-pvr-hts/Manifest
@@ -5,3 +5,4 @@ DIST kodi-pvr-hts-4.4.16.tar.gz 160594 BLAKE2B 5ae9bff9ec9460c860b6333f93748d70c
DIST kodi-pvr-hts-4.4.17.tar.gz 161495 BLAKE2B 494d63cd77d6ada7090418140e7aebdb678941236fe45fc46464b213090a2cb5e386d0a59b589afc36cc4cbe020bd3205341b6d893de61c106aee55747172e18 SHA512 0c9eeb8194e4c5b54d5d4df86dc794604d8df91ef172eff9207001ece9a485f7eea40ece449c28bb4cbb414a5a195e6fc50b9571744420c76da104f5fadff377
DIST kodi-pvr-hts-4.4.18.tar.gz 161525 BLAKE2B 22d869989fc2151ca5ec39c7802d4612d2dcf5e29065bb27a45f528b939f94835585a6a5d427c29a79bea31f5cae811e450be6d80a30d0a18d6934eb63eff395 SHA512 1a0fd0fdec46178262c3f03544d02d13601858043d58ff71bae97c60514f3b11edf12fa53e4436a0de13dcb6877e937d37a5a02f7d6b9ebebbcec9c39e357ce9
DIST kodi-pvr-hts-4.4.20.tar.gz 161693 BLAKE2B d69e72c8d189b540f2d8abc97c50e5a9e93346823333fe2441d3f7b625b94de72dfe50f6e8af5d17506265746819fff1a3d1f1e06ba7b79934ce234151940525 SHA512 aa8ed5487fa00c7cdc13aa167f103daa2a2cbfd93da2414fa85a339edbca3dda056e1073d52bd3a752e00652e83e3c5ddd1de42741600b9da143b18557f598be
+DIST kodi-pvr-hts-7.1.1.tar.gz 167379 BLAKE2B f2391d7997a7e17ed1fb7b2326cdb0cddfecdf9a6b0785fc89ecf8b58004575c6b7a1f6efb976edda827b9e83d334e0bba518498886c1e1769b9ed1deacf25d7 SHA512 5d1e049c23e82964ab87b22c716028d57322f81b749f84f07f66e3bbd2990e711186eee2b562d1f326a369b5fc52d1f7b2aea31b4d8edc827f6555965fec2b69
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.1.1.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.1.1.ebuild
new file mode 100644
index 000000000000..764206faf8d3
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-tv/kodi-19*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
index df5b0487b346..6c70bf3c61b3 100644
--- a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
inherit git-r3
else
- CODENAME="Leia"
+ CODENAME="Matrix"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
@@ -26,7 +26,6 @@ IUSE=""
DEPEND="
=dev-libs/libplatform-2*
- ~media-libs/kodi-platform-9999
~media-tv/kodi-9999
"