summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-27 11:53:45 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-27 11:55:05 -0400
commitcd9cafad78a04068e40280c1e061610c3be5353b (patch)
treeb8a2857e04433bc42b9500b336d0ee225c5db78b /media-libs
parentmedia-video/libva-utils: Version bump to 2.21.0 (diff)
downloadgentoo-cd9cafad78a04068e40280c1e061610c3be5353b.tar.gz
gentoo-cd9cafad78a04068e40280c1e061610c3be5353b.tar.bz2
gentoo-cd9cafad78a04068e40280c1e061610c3be5353b.zip
media-libs/libva-intel-media-driver: Version bump to 24.1.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libva-intel-media-driver/Manifest1
-rw-r--r--media-libs/libva-intel-media-driver/libva-intel-media-driver-24.1.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/libva-intel-media-driver/Manifest b/media-libs/libva-intel-media-driver/Manifest
index 686af388b7b9..e0610cf81f17 100644
--- a/media-libs/libva-intel-media-driver/Manifest
+++ b/media-libs/libva-intel-media-driver/Manifest
@@ -1,2 +1,3 @@
DIST intel-media-24.1.3.tar.gz 25817697 BLAKE2B 683c22c484b5b10ad392e98bb75e85652f8e3b0ca9d06ab08d8c23fe71f46cb34804722405c70727b97a9bdf13c7610518a093a674996e35affed7a327ed9d83 SHA512 4f1844422ebad74f698ae5d14fd8e0bf7d9b2c4e98edb8f7c0a36957f8ebb43bc0191fab36b9b7b57d96f44ec3bb1f3dcba7b2c74f51786164d9380fb3523c3e
DIST intel-media-24.1.4.tar.gz 25821533 BLAKE2B 9c9d18f7c5a9b2016daa1df8e208f6ba2670fc353f72faec5f57f82bef69fcc9987cd81b4913e831e19930692631648fe9bc7a364486e51aa165f722af8c2e0b SHA512 ca590c1ffe5c38959717d48fdee893aab5896df45e3e80618cb63fa9cfc502688e68b5cc45d6e20ddd496b546906829852dfdb296f5fe4b1fec396878417fe23
+DIST intel-media-24.1.5.tar.gz 25834293 BLAKE2B 076731a57c7fbf6776df393c631e8abda7e07679b5babb28a8973b9919ce6522b3bfa92f9a1fcb173714a2c7dedec79a791a8e94d3e1962df072d1b2157692b9 SHA512 9c8121345f23153361f6458b638938896c42542c80efb0490847aa04c873a0726199985318ee6691f240def12d4f18e804971040dc1284b0cd46287756bb61ba
diff --git a/media-libs/libva-intel-media-driver/libva-intel-media-driver-24.1.5.ebuild b/media-libs/libva-intel-media-driver/libva-intel-media-driver-24.1.5.ebuild
new file mode 100644
index 000000000000..c39052ca1e08
--- /dev/null
+++ b/media-libs/libva-intel-media-driver/libva-intel-media-driver-24.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VA-API (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD redistributable? ( no-source-code )"
+SLOT="0"
+IUSE="+redistributable test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-22.3.14:=[${MULTILIB_USEDEP}]
+ >=media-libs/libva-2.20.0[X?,${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.3.4-Remove-unwanted-CFLAGS.patch
+ "${FILESDIR}"/${PN}-23.3.4_testing_in_src_test.patch
+)
+
+multilib_src_configure() {
+ # https://github.com/intel/media-driver/issues/356
+ append-cxxflags -D_FILE_OFFSET_BITS=64
+
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
+ -DENABLE_NONFREE_KERNELS=$(usex redistributable)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}