summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-06-17 14:22:56 -0400
committerJames Le Cuirot <chewi@gentoo.org>2020-09-02 22:33:41 +0100
commit29cf71b138094bba89e9f78a61987f3e5255151f (patch)
tree3741bf1b01906c0ba8dc773fd01558118423e94d /media-libs/zmusic
parentapp-crypt/signify: Version bump to 29 (diff)
downloadgentoo-29cf71b138094bba89e9f78a61987f3e5255151f.tar.gz
gentoo-29cf71b138094bba89e9f78a61987f3e5255151f.tar.bz2
gentoo-29cf71b138094bba89e9f78a61987f3e5255151f.zip
media-libs/zmusic: New package
Bug: https://bugs.gentoo.org/727448 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/zmusic')
-rw-r--r--media-libs/zmusic/Manifest1
-rw-r--r--media-libs/zmusic/metadata.xml16
-rw-r--r--media-libs/zmusic/zmusic-1.1.2.ebuild51
3 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/zmusic/Manifest b/media-libs/zmusic/Manifest
new file mode 100644
index 000000000000..b9b106f73028
--- /dev/null
+++ b/media-libs/zmusic/Manifest
@@ -0,0 +1 @@
+DIST zmusic-1.1.2.tar.gz 1528782 BLAKE2B 0d6896b6aaa290fbc88ac9da3e0a3a34265d93e906ef9aa5039e96a1e39c626f843667c04601bfbfd055e53c30bc843ce3d127e89e14ea56b0112a355ed1ee75 SHA512 97fbedd08b7d0ae84c10b87c615e166b0f14a50173df5081baaa9656d2ce161d413c4568e3985122befe30f36dce4fbad049bf5df3cccb3f2a5147a7bd0d2886
diff --git a/media-libs/zmusic/metadata.xml b/media-libs/zmusic/metadata.xml
new file mode 100644
index 000000000000..32e30ae67be6
--- /dev/null
+++ b/media-libs/zmusic/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="fluidsynth">Enable support for MIDI via <pkg>media-sound/fluidsynth</pkg></flag>
+ <flag name="mpg123">Enable support for MPEG audio playback via <pkg>media-sound/mpg123</pkg></flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/coelckers/ZMusic/issues</bugs-to>
+ <remote-id type="github">coelckers/ZMusic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/zmusic/zmusic-1.1.2.ebuild b/media-libs/zmusic/zmusic-1.1.2.ebuild
new file mode 100644
index 000000000000..dbcf8b761784
--- /dev/null
+++ b/media-libs/zmusic/zmusic-1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="ZMusic"
+DESCRIPTION="GZDoom's music system as a standalone library"
+HOMEPAGE="https://github.com/coelckers/ZMusic"
+SRC_URI="https://github.com/coelckers/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD DUMB-0.9.3 GPL-3 LGPL-2.1+ LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fluidsynth mpg123 sndfile"
+
+DEPEND="
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mpg123? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ rm -rf licenses || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFORCE_INTERNAL_ZLIB=OFF
+ -DFORCE_INTERNAL_GME=ON
+ -DDYN_FLUIDSYNTH=OFF
+ -DDYN_SNDFILE=OFF
+ -DDYN_MPG123=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_ALSA="$(usex !alsa)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_FluidSynth="$(usex !fluidsynth)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_MPG123="$(usex !mpg123)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_SndFile="$(usex !sndfile)"
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}