summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 16:08:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 16:08:14 +0200
commit90854fa35481088a542bba181035942089b515a2 (patch)
tree23d1ecd9920190e9591c5c0d3b32a5c9df650179 /media-libs/x264
parentsys-kernel/gentoo-sources: Linux patch 4.1.25 (diff)
downloadgentoo-90854fa35481088a542bba181035942089b515a2.tar.gz
gentoo-90854fa35481088a542bba181035942089b515a2.tar.bz2
gentoo-90854fa35481088a542bba181035942089b515a2.zip
media-libs/x264: update cflags patch for live ebuild; bug #581196
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/files/x264-0.0.20160523-cflags.patch40
-rw-r--r--media-libs/x264/x264-9999.ebuild4
2 files changed, 42 insertions, 2 deletions
diff --git a/media-libs/x264/files/x264-0.0.20160523-cflags.patch b/media-libs/x264/files/x264-0.0.20160523-cflags.patch
new file mode 100644
index 000000000000..25b7e2edb39f
--- /dev/null
+++ b/media-libs/x264/files/x264-0.0.20160523-cflags.patch
@@ -0,0 +1,40 @@
+Index: x264-9999/configure
+===================================================================
+--- x264-9999.orig/configure
++++ x264-9999/configure
+@@ -667,8 +667,6 @@ case $host_cpu in
+ if [[ "$asm" == auto && "$CFLAGS" != *-mfpmath* ]]; then
+ CFLAGS="$CFLAGS -mfpmath=sse -msse -msse2"
+ fi
+- CFLAGS="-m32 $CFLAGS"
+- LDFLAGS="-m32 $LDFLAGS"
+ fi
+ if [ "$SYS" = MACOSX ]; then
+ ASFLAGS="$ASFLAGS -f macho32 -DPREFIX"
+@@ -687,13 +685,8 @@ case $host_cpu in
+ AS_EXT=".asm"
+ ASFLAGS="$ASFLAGS -DARCH_X86_64=1 -I\$(SRCPATH)/common/x86/"
+ stack_alignment=16
+- [ $compiler = GNU ] && CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
+ if [ "$SYS" = MACOSX ]; then
+ ASFLAGS="$ASFLAGS -f macho64 -DPIC -DPREFIX"
+- if cc_check '' "-arch x86_64"; then
+- CFLAGS="$CFLAGS -arch x86_64"
+- LDFLAGS="$LDFLAGS -arch x86_64"
+- fi
+ elif [ "$SYS" = WINDOWS -o "$SYS" = CYGWIN ]; then
+ ASFLAGS="$ASFLAGS -f win64"
+ if [ $compiler = GNU ]; then
+@@ -1173,10 +1166,10 @@ if [ "$strip" = "yes" ]; then
+ fi
+
+ if [ "$debug" = "yes" ]; then
+- CFLAGS="-O1 -g $CFLAGS"
++ CFLAGS="$CFLAGS"
+ RCFLAGS="$RCFLAGS -DDEBUG"
+ else
+- CFLAGS="-O3 -ffast-math $CFLAGS"
++ CFLAGS="-ffast-math $CFLAGS"
+ fi
+
+ if cc_check '' -fno-tree-vectorize ; then
diff --git a/media-libs/x264/x264-9999.ebuild b/media-libs/x264/x264-9999.ebuild
index f097db63aed7..278f1fee4f8f 100644
--- a/media-libs/x264/x264-9999.ebuild
+++ b/media-libs/x264/x264-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -38,7 +38,7 @@ DOCS="AUTHORS doc/*.txt"
src_prepare() {
# Initial support for x32 ABI, bug #420241
# Avoid messing too much with CFLAGS.
- epatch "${FILESDIR}"/x264-0.0.20151011-cflags.patch
+ epatch "${FILESDIR}"/x264-0.0.20160523-cflags.patch
}
multilib_src_configure() {