summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-11 12:03:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-11 12:03:34 +0100
commit36653e1b24d307c5280722b0fe530c341b098042 (patch)
treeba2613a7c31fad41ed0639eb7acde5f55045ecfd /media-libs/vo-aacenc
parentmedia-libs/vo-aacenc: remove old (diff)
downloadgentoo-36653e1b24d307c5280722b0fe530c341b098042.tar.gz
gentoo-36653e1b24d307c5280722b0fe530c341b098042.tar.bz2
gentoo-36653e1b24d307c5280722b0fe530c341b098042.zip
media-libs/vo-aacenc: Append -mfpu=neon when USE=neon is set, it does not build otherwise. Bug #608878.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/vo-aacenc')
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild5
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
index a1443bc0fa92..783c9ac2153a 100644
--- a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
AUTOTOOLS_AUTORECONF=yes
fi
-inherit autotools-multilib ${SCM}
+inherit autotools-multilib flag-o-matic ${SCM}
DESCRIPTION="VisualOn AAC encoder library"
HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
@@ -34,6 +34,7 @@ IUSE="examples static-libs neon"
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
src_configure() {
+ use neon && append-flags '-mfpu=neon'
local myeconfargs=(
"$(use_enable examples example)"
"$(use_enable neon armv7neon)"
diff --git a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
index 7d154fcff6eb..2aed642b20db 100644
--- a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
+++ b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
AUTOTOOLS_AUTORECONF=yes
fi
-inherit autotools-multilib ${SCM}
+inherit autotools-multilib flag-o-matic ${SCM}
DESCRIPTION="VisualOn AAC encoder library"
HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
@@ -34,6 +34,7 @@ IUSE="examples static-libs neon"
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
src_configure() {
+ use neon && append-flags '-mfpu=neon'
local myeconfargs=(
"$(use_enable examples example)"
"$(use_enable neon armv7neon)"