summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libpano13
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libpano13')
-rw-r--r--media-libs/libpano13/Manifest2
-rw-r--r--media-libs/libpano13/libpano13-2.9.18.ebuild45
-rw-r--r--media-libs/libpano13/libpano13-2.9.19.ebuild40
-rw-r--r--media-libs/libpano13/metadata.xml8
4 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/libpano13/Manifest b/media-libs/libpano13/Manifest
new file mode 100644
index 000000000000..8c411b32547a
--- /dev/null
+++ b/media-libs/libpano13/Manifest
@@ -0,0 +1,2 @@
+DIST libpano13-2.9.18.tar.gz 2723032 SHA256 de5d4e43f15c3430e95c0faa1c50c9503516e1b570d0ec0522f610a578caa172 SHA512 bd8449a8ee01e990fa19784889c1afb0e64f90e25596c872e7470fb700c327aad4fc0c565977576dac34dca4cea55a46aad9dc547d3ee4ab6b353cd8b6656874 WHIRLPOOL d83760702798cf1f17c79c3a1b030d6e04bcb7aa39c3e4dbc6cddaaded42c6f19fa683aa048c97ba91651fc58c8adceb6dec61ff7d820dc925400f7e6a2c663d
+DIST libpano13-2.9.19.tar.gz 3527845 SHA256 037357383978341dea8f572a5d2a0876c5ab0a83dffda431bd393357e91d95a8 SHA512 f9f147426d44d8babac09cb1a1b5111f88b9c2fc079f33df80133492bcf24cbd1edd771e6bec7bed4b0256bf15c700139c0a83119d3adf296ae5c567e006d868 WHIRLPOOL d114ddcc46eb920c1d603665d4d22ed18aa8c92f03c4e02ec2db526ae1236b6aeaa8ff3e6827b4fcb0c6361dbcf290afac5f63d051105eb43427b567d6cbccab
diff --git a/media-libs/libpano13/libpano13-2.9.18.ebuild b/media-libs/libpano13/libpano13-2.9.18.ebuild
new file mode 100644
index 000000000000..3a80d3c04a36
--- /dev/null
+++ b/media-libs/libpano13/libpano13-2.9.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator java-pkg-opt-2
+
+DESCRIPTION="Helmut Dersch's panorama toolbox library"
+HOMEPAGE="http://panotools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/panotools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="java static-libs"
+
+DEPEND="media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+ java? ( >=virtual/jdk-1.3 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+src_configure() {
+ LIBS="-lm" econf \
+ $(use_with java java ${JAVA_HOME}) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README README.linux AUTHORS NEWS doc/*.txt
+
+ if ! use static-libs ; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}
+
+pkg_postinst() {
+ ewarn "you should remerge all reverse dependencies (media-gfx/hugin and"
+ ewarn "media-gfx/autopano-sift-C) as they might not work anymore"
+}
diff --git a/media-libs/libpano13/libpano13-2.9.19.ebuild b/media-libs/libpano13/libpano13-2.9.19.ebuild
new file mode 100644
index 000000000000..63fd17234cbf
--- /dev/null
+++ b/media-libs/libpano13/libpano13-2.9.19.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator java-pkg-opt-2 eutils
+
+DESCRIPTION="Helmut Dersch's panorama toolbox library"
+HOMEPAGE="http://panotools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/panotools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/3"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="java static-libs"
+
+DEPEND="media-libs/libpng:0=
+ media-libs/tiff:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ java? ( >=virtual/jdk-1.3 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+src_configure() {
+ LIBS="-lm" econf \
+ $(use_with java java ${JAVA_HOME}) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README README.linux AUTHORS NEWS doc/*.txt
+
+ if ! use static-libs ; then
+ prune_libtool_files
+ fi
+}
diff --git a/media-libs/libpano13/metadata.xml b/media-libs/libpano13/metadata.xml
new file mode 100644
index 000000000000..9530e85e3dfd
--- /dev/null
+++ b/media-libs/libpano13/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">panotools</remote-id>
+ </upstream>
+</pkgmetadata>