summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-20 15:55:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-20 15:55:23 +0100
commit12636e5e7a3c5050124c2ffd12f2d851573b5290 (patch)
tree075a4cfc1702d3a4dd3057737389f212ca3b052e /media-libs/jasper
parentmedia-libs/jasper: Bumped live ebuild to EAPI-7 (diff)
downloadgentoo-12636e5e7a3c5050124c2ffd12f2d851573b5290.tar.gz
gentoo-12636e5e7a3c5050124c2ffd12f2d851573b5290.tar.bz2
gentoo-12636e5e7a3c5050124c2ffd12f2d851573b5290.zip
media-libs/jasper: Bump to version 2.0.15
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/jasper')
-rw-r--r--media-libs/jasper/Manifest1
-rw-r--r--media-libs/jasper/jasper-2.0.15.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/jasper/Manifest b/media-libs/jasper/Manifest
index a36492e7b897..93b549102069 100644
--- a/media-libs/jasper/Manifest
+++ b/media-libs/jasper/Manifest
@@ -1 +1,2 @@
DIST jasper-2.0.14.tar.gz 1311825 BLAKE2B 0cd2feb5a73aaa2da6f1d105fefe98f57c6a5ecf92f6449891f49eca0b5926bc683a03bf933b920cad95883134cf292405f244f10b3bbe7867a41f2dde80337e SHA512 6b270cb1eb55f777f30016f3258e5e2297627e7d086334814c308464f5a4552c23241b0fdbc81ea715a6f4746294657f96c1cb6ceb320629ce57db7e81d84940
+DIST jasper-2.0.15.tar.gz 1311926 BLAKE2B 39b6e0af590bbf849a172b97148465e68b9b5682286b882e41bf8f58e3ff4f18a4762a29b08529d9589a63aa22a9125aeed8c2dc7e61198f5eb15f1ca7b60ae0 SHA512 360cadfa0f3cb502ce6354267df71a48bac5a5f6bf60c280f6943c8ede72c727ca178cad411c7824c727731aaa7def92298ebd259a262d9776c6e137f12b16c7
diff --git a/media-libs/jasper/jasper-2.0.15.ebuild b/media-libs/jasper/jasper-2.0.15.ebuild
new file mode 100644
index 000000000000..39254dafd4cc
--- /dev/null
+++ b/media-libs/jasper/jasper-2.0.15.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
+HOMEPAGE="https://www.ece.uvic.ca/~mdadams/jasper/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+else
+ SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${PN}-version-${PV}"
+fi
+
+# We limit memory usage to 128 MiB by default, specified in bytes
+: ${JASPER_MEM_LIMIT:=134217728}
+
+LICENSE="JasPer2.0"
+SLOT="0/4"
+IUSE="doc jpeg opengl test"
+
+RDEPEND="
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
+ >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DALLOW_IN_SOURCE_BUILD=OFF
+ -DBASH_PROGRAM="${EPREFIX}"/bin/bash
+ -DJAS_ENABLE_ASAN=OFF
+ -DJAS_ENABLE_LSAN=OFF
+ -DJAS_ENABLE_MSAN=OFF
+ -DJAS_ENABLE_SHARED=ON
+ -DJAS_ENABLE_STRICT=ON
+ -DJAS_ENABLE_USAN=OFF
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+
+ # JPEG
+ -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
+ -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
+
+ # OpenGL
+ -DJAS_ENABLE_OPENGL=$(usex opengl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
+
+ # Doxygen
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
+
+ -DJAS_ENABLE_PROGRAMS=$(usex test)
+ )
+ cmake-utils_src_configure
+}