summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-05-08 12:55:49 +0300
committerSam James <sam@gentoo.org>2022-05-12 22:42:34 +0000
commit3915b764b76507c595f389ff6870bb1d79c3ef52 (patch)
treed9f568b7773c195ce68a88f4581e5f318c30e7dd /media-libs/gst-plugins-good
parentapp-emacs/haxe-mode: new package; add version 0.3.3 (diff)
downloadgentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.gz
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.bz2
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.zip
media-libs/gstreamer: Version bump, 1.20.2
Bug: https://bugs.gentoo.org/843770 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 7f7eecc061a2..1ef4a23337dc 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-good-1.16.3.tar.xz 3914676 BLAKE2B 52f18027f9d9a77e8b459a0a10fa
DIST gst-plugins-good-1.18.4.tar.xz 3277572 BLAKE2B 8acfb975d19eabc681184d0096328051a9a02e5f849599dbad1233a0e9254e1a2d2bef75d8afdc779a7ca01a71b15d1e83a843749c0ef5f7ab2b5818067ab898 SHA512 764c66383c93e57f9c5e7742002013e07e7b25750d6974d6c07744433e8ceb7570e829e68278e2bc5214f77158311a6b3bfb013d615cf66205d8d7a9e2d54b86
DIST gst-plugins-good-1.18.6.tar.xz 3296552 BLAKE2B 551ae9cf9beb512ae418db20cd50dc8826ed60421a40d6c9c9fc558f32c9db2a9bada309a8075306542c53382ecb728dac3dd6252d1efc7255cffde0bea35895 SHA512 e0be5f1eaffe65d7871f23e42645fa4cee30953d16d54c4f4707c094859659cff1e4609b086afebaf08777b6d01dcba4f4b2b338e722bf729e9ed0482a2417a5
DIST gst-plugins-good-1.20.1.tar.xz 3415220 BLAKE2B 62a0e0b4d60412350c3aad692e7b3d0dd5c7ebed098e21e7d4d7c599ffec9be5795c88cbdece0b219d1aad607ad1a0209a376a8f3543793c9c905cb1401e92c4 SHA512 6e56f6290465da03bfe162228829e51091896b2c5fe9d1d0718f663a3ab14edf5c790b37998a783981b9c77034252e7dee9fec5136f92ced44c4898e2fbd402e
+DIST gst-plugins-good-1.20.2.tar.xz 3411008 BLAKE2B 45eb497d240bf9b05cfbf85babe5ef85fb8a7f25f1b470f131f319064e1dc04f334d4b7dede4f0aedd73dca01605b7e00e2ddc587bcf9ccce6989a9e99776cb1 SHA512 a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild
new file mode 100644
index 000000000000..de6939296c03
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit flag-o-matic gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="bz2"
+
+ local emesonargs=(
+ -Dbz2=enabled
+
+ # gst-plugins-ximagesrc
+ -Dximagesrc=disabled
+ -Dximagesrc-xshm=disabled
+ -Dximagesrc-xfixes=disabled
+ -Dximagesrc-xdamage=disabled
+
+ # gst-plugins-v4l2
+ -Dv4l2=disabled
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}