summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-10-02 20:13:13 +0000
committerMike Gilbert <floppym@gentoo.org>2019-12-06 15:26:15 -0500
commit40ecf304b834e5c7412e507f741a04840c7f4b41 (patch)
treec1dfb688615666cdedc3604d67ee3a0bf39884e8 /media-libs/dav1d
parentdev-libs/oniguruma: Add live ebuild. (diff)
downloadgentoo-40ecf304b834e5c7412e507f741a04840c7f4b41.tar.gz
gentoo-40ecf304b834e5c7412e507f741a04840c7f4b41.tar.bz2
gentoo-40ecf304b834e5c7412e507f741a04840c7f4b41.zip
media-libs/dav1d: Update meson options.
build_asm was renamed to enable_asm in: https://code.videolan.org/videolan/dav1d/commit/beda6e0d1c37f06e4e03f7ebe13311bd8b18245e Fixes: https://bugs.gentoo.org/696244 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/dav1d-0.4.0.ebuild7
-rw-r--r--media-libs/dav1d/dav1d-0.5.1.ebuild7
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild7
3 files changed, 12 insertions, 9 deletions
diff --git a/media-libs/dav1d/dav1d-0.4.0.ebuild b/media-libs/dav1d/dav1d-0.4.0.ebuild
index c344ddc2e4e4..1bfd1838576c 100644
--- a/media-libs/dav1d/dav1d-0.4.0.ebuild
+++ b/media-libs/dav1d/dav1d-0.4.0.ebuild
@@ -36,15 +36,16 @@ multilib_src_configure() {
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )
+ local enable_asm
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
- build_asm=false
+ enable_asm=false
else
- build_asm=$(usex asm true false)
+ enable_asm=$(usex asm true false)
fi
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
- -D build_asm=$build_asm
+ -D enable_asm=${enable_asm}
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-0.5.1.ebuild b/media-libs/dav1d/dav1d-0.5.1.ebuild
index 69a1a98df066..2d5b991ec5d9 100644
--- a/media-libs/dav1d/dav1d-0.5.1.ebuild
+++ b/media-libs/dav1d/dav1d-0.5.1.ebuild
@@ -34,15 +34,16 @@ multilib_src_configure() {
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )
+ local enable_asm
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
- build_asm=false
+ enable_asm=false
else
- build_asm=$(usex asm true false)
+ enable_asm=$(usex asm true false)
fi
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
- -D build_asm=$build_asm
+ -D enable_asm=${enable_asm}
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index 69a1a98df066..2d5b991ec5d9 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -34,15 +34,16 @@ multilib_src_configure() {
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )
+ local enable_asm
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
- build_asm=false
+ enable_asm=false
else
- build_asm=$(usex asm true false)
+ enable_asm=$(usex asm true false)
fi
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
- -D build_asm=$build_asm
+ -D enable_asm=${enable_asm}
)
meson_src_configure
}