summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-04-01 00:25:04 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-04 23:09:31 +0200
commite3d35f35dfabcb6b2b282313d5f9e9555ac98e91 (patch)
tree31ec9e735111550b64c53845d74fa44564031d32 /media-gfx
parentmedia-gfx/dawn: Update to EAPI-6 and revbump (diff)
downloadgentoo-e3d35f35dfabcb6b2b282313d5f9e9555ac98e91.tar.gz
gentoo-e3d35f35dfabcb6b2b282313d5f9e9555ac98e91.tar.bz2
gentoo-e3d35f35dfabcb6b2b282313d5f9e9555ac98e91.zip
media-gfx/dawn: Fix building with GCC-7
Bug: https://bugs.gentoo.org/638616 Closes: https://bugs.gentoo.org/638616 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/dawn/dawn-3.90b-r1.ebuild5
-rw-r--r--media-gfx/dawn/dawn-3.90b.ebuild3
-rw-r--r--media-gfx/dawn/files/dawn-3.90b-gcc7.patch21
3 files changed, 27 insertions, 2 deletions
diff --git a/media-gfx/dawn/dawn-3.90b-r1.ebuild b/media-gfx/dawn/dawn-3.90b-r1.ebuild
index b7d6d5d11ea2..739ba96e10a9 100644
--- a/media-gfx/dawn/dawn-3.90b-r1.ebuild
+++ b/media-gfx/dawn/dawn-3.90b-r1.ebuild
@@ -25,7 +25,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
-PATCHES=( "${FILESDIR}"/${P}-no-interactive.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-no-interactive.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+)
src_prepare() {
default
diff --git a/media-gfx/dawn/dawn-3.90b.ebuild b/media-gfx/dawn/dawn-3.90b.ebuild
index 9e9e200f5fd6..d3f9a78279fa 100644
--- a/media-gfx/dawn/dawn-3.90b.ebuild
+++ b/media-gfx/dawn/dawn-3.90b.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=2
@@ -27,6 +27,7 @@ S="${WORKDIR}/${MYP}"
src_prepare() {
epatch "${FILESDIR}"/${P}-no-interactive.patch
+ epatch "${FILESDIR}"/${P}-gcc7.patch
sed -i -e "s/\$(LIB_DIR)/\$(LDFLAGS) &/" \
-e '/strip/d' Makefile*in || die
}
diff --git a/media-gfx/dawn/files/dawn-3.90b-gcc7.patch b/media-gfx/dawn/files/dawn-3.90b-gcc7.patch
new file mode 100644
index 000000000000..e144a38df8f0
--- /dev/null
+++ b/media-gfx/dawn/files/dawn-3.90b-gcc7.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/638616
+
+--- a/FRString.h
++++ b/FRString.h
+@@ -137,13 +137,13 @@
+ char* p = m_string ;
+
+ // skip first blank if any
+- while( isspace(*p) && p != '\0' ) {p++;}
++ while( isspace(*p) && *p != '\0' ) {p++;}
+
+ // skip one word
+- while( !isspace(*p) && p != '\0' ) {p++;}
++ while( !isspace(*p) && *p != '\0' ) {p++;}
+
+ // skip second blank if any
+- while( isspace(*p) && p != '\0' ) {p++;}
++ while( isspace(*p) && *p != '\0' ) {p++;}
+
+ // reset string
+ strcpy( tmp, p );