summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-24 13:35:35 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-24 13:44:41 -0700
commit779b88f745d5fe1361a4cda483cc5520432259ad (patch)
treebf9b130d9500bae9c29662b1c6899c0615cb988e /media-gfx
parentmedia-gfx/eog: Version bump to 42.1 (diff)
downloadgentoo-779b88f745d5fe1361a4cda483cc5520432259ad.tar.gz
gentoo-779b88f745d5fe1361a4cda483cc5520432259ad.tar.bz2
gentoo-779b88f745d5fe1361a4cda483cc5520432259ad.zip
media-gfx/eog-plugins: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 462556e24dbb..9ba1c2341840 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,2 +1,3 @@
DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
DIST eog-plugins-42.0.tar.xz 132008 BLAKE2B 0dbe9ddcdf8f9a7f4da46caffe091a5d6e09327e1277b41474ecf8a3ec63ee7217fdc0cbafd1c47007f83b8ae30f30d91031c76f31473df79cda01aee23314ea SHA512 297b31fefa28f4eda73734ddcdb7702b9c9fa3493b4c13d3bf013e24ddb9015299bcd8f2af6a1976c4bf8c694fea0cc9699e82755d5e0689e71738a6d2fb2fe4
+DIST eog-plugins-42.1.tar.xz 131656 BLAKE2B e561e7b31daf950c1e1c1e1038bf40101b658583160439f7fd9050b52da2f6dd943105e1e1eeaefff7ed2aa759f8b96aad0a65130daba038733967db37158bfc SHA512 4688cb9cce044137717521a3ff2f769f960f12ec8b3f711971f276334f91915c8a3142aff2feb3d24d2eeb86223f040e9b699a1136e7fc7e96202a06b1cda1a8
diff --git a/media-gfx/eog-plugins/eog-plugins-42.1.ebuild b/media-gfx/eog-plugins/eog-plugins-42.1.ebuild
new file mode 100644
index 000000000000..ddb7d165e7af
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}