summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-21 21:48:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-11-29 09:28:29 +0200
commit3129ce9d0d93d3e3d6ab50921f4ddcc6d8242caa (patch)
tree59ee46227d074e961cd546f95a7e6136fdcf8a6c /media-gfx
parentnet-misc/teamviewer: remove old (diff)
downloadgentoo-3129ce9d0d93d3e3d6ab50921f4ddcc6d8242caa.tar.gz
gentoo-3129ce9d0d93d3e3d6ab50921f4ddcc6d8242caa.tar.bz2
gentoo-3129ce9d0d93d3e3d6ab50921f4ddcc6d8242caa.zip
media-gfx/viewnior: Version bump 1.8.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/23024 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/viewnior/Manifest1
-rw-r--r--media-gfx/viewnior/viewnior-1.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/viewnior/Manifest b/media-gfx/viewnior/Manifest
index 3327279caaf6..7ce6c08a0f12 100644
--- a/media-gfx/viewnior/Manifest
+++ b/media-gfx/viewnior/Manifest
@@ -1 +1,2 @@
DIST viewnior-1.7.tar.gz 165719 BLAKE2B 906ab0b632fcc102ac62dd77d6742c2121c46cd92adc0dfe9ba772bf697eff356519dbb6219016a6470903c855aa4c9081f0d61ca1607d8d1b6d8e03236a19bc SHA512 5ba17d7b5ceeffa65b04213f179c1439b09ac44e412e0750dde159b118a714f28d3a290509a402b234e4e7ba5b185fc73eef65d418598f344911e4e2c1373fe5
+DIST viewnior-1.8.tar.gz 169219 BLAKE2B 6f6da16aa987acce8a48d24a645e1c033f113bb6e291da9f17810a7a04e5007d27c2f1afe3c62cc2d192003633a4128fb04a031160fbd51efbd0bb7dfabd8970 SHA512 0f9698801172ef6b8f5df4132526b2e605e9aa9fd69cf41a091a3623de9b2e84ca857e625aaa9e83f29df318f70a13fb458bac0df11ae46837b78ef257a00bee
diff --git a/media-gfx/viewnior/viewnior-1.8.ebuild b/media-gfx/viewnior/viewnior-1.8.ebuild
new file mode 100644
index 000000000000..03ce179e58af
--- /dev/null
+++ b/media-gfx/viewnior/viewnior-1.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Fast and simple image viewer"
+HOMEPAGE="https://siyanpanayotov.com/project/viewnior"
+SRC_URI="https://github.com/hellosiyan/${PN^}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/exiv2:0=
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN^}-${P}"
+
+src_prepare() {
+ # That script would update icon cache and desktop database.
+ sed -i "s/meson.add_install_script('meson_post_install.py')//" meson.build \
+ || die 'Failed to remove post-install-script invocation from meson.build'
+ # Don't let meson compress the manpage.
+ sed -i "s/subdir('man')//" meson.build \
+ || die 'Failed to remove manpage compression from meson.build'
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ doman man/viewnior.1
+}