summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-22 19:32:09 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-22 21:41:24 -0400
commit6cde3637fe7ca08fee56dc0c34ec7e0acdb095e9 (patch)
tree146a22c8e4f1909211e0ceff6a452f21f7f99fdf /media-gfx/shotwell
parentmedia-gfx/eog: Version bump to 44.1 (diff)
downloadgentoo-6cde3637fe7ca08fee56dc0c34ec7e0acdb095e9.tar.gz
gentoo-6cde3637fe7ca08fee56dc0c34ec7e0acdb095e9.tar.bz2
gentoo-6cde3637fe7ca08fee56dc0c34ec7e0acdb095e9.zip
media-gfx/shotwell: Version bump to 0.32.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30713 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.32.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index ebab828a7044..bf82582d1ed8 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,2 +1,3 @@
DIST shotwell-0.30.17.tar.xz 6533460 BLAKE2B 58ec94f21bf465dcc19760f40235db7d2ad7d00c214802cd3ad6cfd67cb1088a5999f183c8ae36398e492a1b387e6ea717a9b8d0f31f4ef369e67c10150ae57a SHA512 f680b6f58538fb7b584594d00da7fe997dbc766583a5b5a85943b3df905dbc7192d3e7b5c7b47b6bd1221280995aaba878ea1afff9b042995bf30fbcbce5f7ea
DIST shotwell-0.31.7.tar.xz 6610144 BLAKE2B b8f69237abb987508f565d5bfd59123fabf2fa1023783362b189da2690a2b72d5908e13c1371097b48db9eddf1b1361b0b92ca1b5e86287dd35b484bbf119593 SHA512 6653cbc2b2147f65d615f6ea879d012e6a5c5b55c9dfcdb8ff9fecf909ee6f5db96ac8124608d8223e0a95ab26508064b9376a293a2bd4fe05a821988400f42e
+DIST shotwell-0.32.0.tar.xz 35326752 BLAKE2B a201e5cc910872730a902d43a8d8b16f882966100bcc061d8c88fcfd43b1d0db54b98691b2d4a40568ddcb9d9ec28ca31c7575db7ae5ee4db304a27d10999c3a SHA512 0ff24d70cc15b68d5c51bc3ff42a10873656e5e16bfa273bb928a68ae569898136a33df92468b682c2ebc662f0bfa53ac7748b4b140d03b9608b68447b738051
diff --git a/media-gfx/shotwell/shotwell-0.32.0.ebuild b/media-gfx/shotwell/shotwell-0.32.0.ebuild
new file mode 100644
index 000000000000..4fdd2e16ec91
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}