summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-01-27 17:37:12 +0000
committerMatthew Smith <matthew@gentoo.org>2024-01-27 17:37:31 +0000
commitdbab74604fc6fea1f0ddc167ca889e567ca6f25a (patch)
treeb1eab33be0812c065701deb610d1814fa4653e35 /media-gfx/renderdoc
parentwww-client/httrack: Stabilize 3.49.5 amd64, #923034 (diff)
downloadgentoo-dbab74604fc6fea1f0ddc167ca889e567ca6f25a.tar.gz
gentoo-dbab74604fc6fea1f0ddc167ca889e567ca6f25a.tar.bz2
gentoo-dbab74604fc6fea1f0ddc167ca889e567ca6f25a.zip
media-gfx/renderdoc: use vendored glslang
Closes: https://bugs.gentoo.org/922436 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'media-gfx/renderdoc')
-rw-r--r--media-gfx/renderdoc/files/renderdoc-1.30-r1-system-compress.patch142
-rw-r--r--media-gfx/renderdoc/renderdoc-1.30-r1.ebuild194
2 files changed, 336 insertions, 0 deletions
diff --git a/media-gfx/renderdoc/files/renderdoc-1.30-r1-system-compress.patch b/media-gfx/renderdoc/files/renderdoc-1.30-r1-system-compress.patch
new file mode 100644
index 000000000000..5b754395cf36
--- /dev/null
+++ b/media-gfx/renderdoc/files/renderdoc-1.30-r1-system-compress.patch
@@ -0,0 +1,142 @@
+From 8f16c974fc8ec0b286d803490baa6e00a83615cf Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Sun, 30 Jan 2022 18:07:51 +0000
+Subject: [PATCH 2/3] build: Use system compression libs
+
+---
+ CMakeLists.txt | 6 +++
+ renderdoc/CMakeLists.txt | 48 +------------------
+ renderdoc/core/replay_proxy.cpp | 2 +-
+ .../driver/shaders/dxbc/dxbc_container.cpp | 2 +-
+ renderdoc/serialise/lz4io.h | 2 +-
+ 5 files changed, 10 insertions(+), 50 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cb0a2c7f6..0ee4fc629 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -473,6 +473,12 @@
+ endif()
+ endif()
+
++find_package(PkgConfig REQUIRED)
++find_package(miniz REQUIRED CONFIG)
++
++pkg_check_modules(lz4 REQUIRED IMPORTED_TARGET liblz4)
++pkg_check_modules(zstd REQUIRED IMPORTED_TARGET libzstd)
++
+ add_subdirectory(renderdoc)
+
+ # these variables are handled within the CMakeLists.txt in qrenderdoc,
+diff --git a/renderdoc/CMakeLists.txt b/renderdoc/CMakeLists.txt
+index 927e95fb9..5908be6de 100644
+--- a/renderdoc/CMakeLists.txt
++++ b/renderdoc/CMakeLists.txt
+@@ -218,56 +218,10 @@ set(sources
+ 3rdparty/pugixml/pugixml.cpp
+ 3rdparty/pugixml/pugixml.hpp
+ 3rdparty/pugixml/pugiconfig.hpp
+- 3rdparty/lz4/lz4.c
+- 3rdparty/lz4/lz4.h
+ 3rdparty/md5/md5.c
+ 3rdparty/md5/md5.h
+- 3rdparty/miniz/miniz.c
+- 3rdparty/miniz/miniz.h
+ 3rdparty/superluminal/superluminal.cpp
+ 3rdparty/superluminal/superluminal.h
+- 3rdparty/zstd/bitstream.h
+- 3rdparty/zstd/compiler.h
+- 3rdparty/zstd/cpu.h
+- 3rdparty/zstd/debug.c
+- 3rdparty/zstd/debug.h
+- 3rdparty/zstd/entropy_common.c
+- 3rdparty/zstd/error_private.c
+- 3rdparty/zstd/error_private.h
+- 3rdparty/zstd/fse.h
+- 3rdparty/zstd/fse_compress.c
+- 3rdparty/zstd/fse_decompress.c
+- 3rdparty/zstd/hist.c
+- 3rdparty/zstd/hist.h
+- 3rdparty/zstd/huf.h
+- 3rdparty/zstd/huf_compress.c
+- 3rdparty/zstd/huf_decompress.c
+- 3rdparty/zstd/mem.h
+- 3rdparty/zstd/pool.c
+- 3rdparty/zstd/pool.h
+- 3rdparty/zstd/threading.c
+- 3rdparty/zstd/threading.h
+- 3rdparty/zstd/xxhash.c
+- 3rdparty/zstd/xxhash.h
+- 3rdparty/zstd/zstd.h
+- 3rdparty/zstd/zstd_common.c
+- 3rdparty/zstd/zstd_compress.c
+- 3rdparty/zstd/zstd_compress_internal.h
+- 3rdparty/zstd/zstd_decompress.c
+- 3rdparty/zstd/zstd_double_fast.c
+- 3rdparty/zstd/zstd_double_fast.h
+- 3rdparty/zstd/zstd_errors.h
+- 3rdparty/zstd/zstd_fast.c
+- 3rdparty/zstd/zstd_fast.h
+- 3rdparty/zstd/zstd_internal.h
+- 3rdparty/zstd/zstd_lazy.c
+- 3rdparty/zstd/zstd_lazy.h
+- 3rdparty/zstd/zstd_ldm.c
+- 3rdparty/zstd/zstd_ldm.h
+- 3rdparty/zstd/zstd_opt.c
+- 3rdparty/zstd/zstd_opt.h
+- 3rdparty/zstd/zstdmt_compress.c
+- 3rdparty/zstd/zstdmt_compress.h
+ 3rdparty/stb/stb_image.h
+ 3rdparty/stb/stb_image_write.h
+ 3rdparty/stb/stb_image_resize.h
+@@ -580,7 +534,7 @@ endif()
+ add_library(renderdoc SHARED ${renderdoc_objects})
+ target_compile_definitions(renderdoc ${RDOC_DEFINITIONS})
+ target_include_directories(renderdoc ${RDOC_INCLUDES})
+-target_link_libraries(renderdoc ${RDOC_LIBRARIES})
++target_link_libraries(renderdoc ${RDOC_LIBRARIES} miniz::miniz PkgConfig::lz4 PkgConfig::zstd)
+
+ add_dependencies(renderdoc renderdoc_libentry)
+
+diff --git a/renderdoc/core/replay_proxy.cpp b/renderdoc/core/replay_proxy.cpp
+index dea1e86cf..c9362e797 100644
+--- a/renderdoc/core/replay_proxy.cpp
++++ b/renderdoc/core/replay_proxy.cpp
+@@ -25,7 +25,7 @@
+
+ #include "replay_proxy.h"
+ #include <list>
+-#include "lz4/lz4.h"
++#include <lz4.h>
+ #include "replay/dummy_driver.h"
+ #include "serialise/lz4io.h"
+
+diff --git a/renderdoc/driver/shaders/dxbc/dxbc_container.cpp b/renderdoc/driver/shaders/dxbc/dxbc_container.cpp
+index ede1fdeb7..0c8fd4dfe 100644
+--- a/renderdoc/driver/shaders/dxbc/dxbc_container.cpp
++++ b/renderdoc/driver/shaders/dxbc/dxbc_container.cpp
+@@ -29,7 +29,7 @@
+ #include "common/common.h"
+ #include "core/settings.h"
+ #include "driver/shaders/dxil/dxil_bytecode.h"
+-#include "lz4/lz4.h"
++#include <lz4.h>
+ #include "md5/md5.h"
+ #include "serialise/serialiser.h"
+ #include "strings/string_utils.h"
+diff --git a/renderdoc/serialise/lz4io.h b/renderdoc/serialise/lz4io.h
+index 199fbbbc1..80fdf94f2 100644
+--- a/renderdoc/serialise/lz4io.h
++++ b/renderdoc/serialise/lz4io.h
+@@ -24,7 +24,7 @@
+
+ #pragma once
+
+-#include "lz4/lz4.h"
++#include <lz4.h>
+ #include "streamio.h"
+
+ class LZ4Compressor : public Compressor
+--
+2.35.1
+
diff --git a/media-gfx/renderdoc/renderdoc-1.30-r1.ebuild b/media-gfx/renderdoc/renderdoc-1.30-r1.ebuild
new file mode 100644
index 000000000000..4fcb8c509c33
--- /dev/null
+++ b/media-gfx/renderdoc/renderdoc-1.30-r1.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The swig fork is required for compatibility with both provided and
+# 3rd-party Python scripts. Required patch was sent to upstream in
+# 2014: https://github.com/swig/swig/pull/251
+MY_SWIG_VER=7
+MY_SWIG=swig-${PN}-${MY_SWIG_VER}
+
+AUTOTOOLS_AUTO_DEPEND="no"
+DOCS_BUILDER="sphinx"
+DOCS_DIR="docs"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools cmake flag-o-matic optfeature python-single-r1 docs qmake-utils verify-sig xdg
+
+DESCRIPTION="A stand-alone graphics debugging tool"
+HOMEPAGE="https://renderdoc.org https://github.com/baldurk/renderdoc"
+SRC_URI="
+ https://github.com/baldurk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ qt5? ( https://github.com/baldurk/swig/archive/${PN}-modified-${MY_SWIG_VER}.tar.gz -> ${MY_SWIG}.tar.gz )
+ verify-sig? ( https://github.com/baldurk/renderdoc/releases/download/v${PV}/v${PV}.tar.gz.asc -> ${P}.tar.gz.asc )
+"
+
+# renderdoc: MIT
+# + cmdline: BSD (not compatible with upstream lib)
+# + farm fresh icons: CC-BY-3.0
+# + half: MIT (not compatible with system dev-libs/half)
+# + include-bin ZLIB (upstream doesn't exist anymore, maintained in tree)
+# + md5: public-domain
+# + plthook: BSD-2
+# + pugixml: MIT
+# + radeon gpu analyzer: MIT
+# + source code pro: OFL-1.1
+# + stb: public-domain
+# + tinyfiledialogs: ZLIB
+# + glslang: BSD
+# + docs? ( sphinx.paramlinks: MIT )
+# swig: GPL-3+ BSD BSD-2
+LICENSE="BSD BSD-2 CC-BY-3.0 GPL-3+ MIT OFL-1.1 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pyside2 qt5"
+REQUIRED_USE="doc? ( qt5 ) pyside2? ( qt5 ) qt5? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ dev-libs/miniz:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ virtual/opengl
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ ')
+ )
+ qt5? (
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+"
+DEPEND="${RDEPEND}"
+# qtcore provides qmake, which is required to build the qrenderdoc gui.
+BDEPEND="
+ x11-base/xorg-proto
+ virtual/pkgconfig
+ qt5? (
+ ${AUTOTOOLS_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libpcre
+ dev-qt/qtcore:5
+ app-alternatives/yacc
+ )
+ verify-sig? ( sec-keys/openpgp-keys-baldurkarlsson )
+"
+
+PATCHES=(
+ # The analytics seem very reasonable, and even without this patch
+ # they are NOT sent before the user accepts. But default the
+ # selection to off, just in case.
+ "${FILESDIR}"/${PN}-1.18-analytics-off.patch
+
+ # Only search for PySide2 if pyside2 USE flag is set.
+ # Bug #833627
+ "${FILESDIR}"/${PN}-1.18-conditional-pyside.patch
+
+ # Pass CXXFLAGS and LDFLAGS through to qmake when qrenderdoc is
+ # built.
+ "${FILESDIR}"/${PN}-1.18-system-flags.patch
+
+ # Needed to prevent sandbox violations during build.
+ "${FILESDIR}"/${PN}-1.27-env-home.patch
+
+ "${FILESDIR}"/${PN}-1.30-r1-system-compress.patch
+)
+
+DOCS=( util/LINUX_DIST_README )
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/baldurkarlsson.gpg
+
+pkg_setup() {
+ use qt5 && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
+ fi
+
+ # Do not unpack the swig sources here. CMake will do that if
+ # required.
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Remove the calls to install the documentation files. Instead,
+ # install them with einstalldocs.
+ sed -i '/share\/doc\/renderdoc/d' \
+ "${S}"/CMakeLists.txt "${S}"/qrenderdoc/CMakeLists.txt \
+ || die 'sed remove doc install failed'
+
+ # Assumes that the build directory is "${S}"/build, which it is not.
+ sed -i "s|../build/lib|${BUILD_DIR}/lib|" \
+ "${S}"/docs/conf.py \
+ || die 'sed patch doc sys.path failed'
+
+ # Bug #836235
+ sed -i '/#include <stdarg/i #include <time.h>' \
+ "${S}"/renderdoc/os/os_specific.h \
+ || die 'sed include time.h failed'
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Build system does not know that this is a tagged release, as
+ # we just have the tarball and not the git repository.
+ -DBUILD_VERSION_STABLE=ON
+
+ -DENABLE_EGL=ON
+ -DENABLE_GL=ON
+ -DENABLE_GLES=ON
+ -DENABLE_PYRENDERDOC=$(usex qt5)
+ -DENABLE_QRENDERDOC=$(usex qt5)
+ -DENABLE_VULKAN=ON
+
+ # Upstream says that this option is unsupported and should not
+ # be used yet.
+ -DENABLE_UNSUPPORTED_EXPERIMENTAL_POSSIBLY_BROKEN_WAYLAND=OFF
+
+ -DENABLE_XCB=ON
+ -DENABLE_XLIB=ON
+
+ # renderdoc_capture.json is installed here
+ -DVULKAN_LAYER_FOLDER="${EPREFIX}"/etc/vulkan/implicit_layer.d
+ )
+
+ use qt5 && mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DRENDERDOC_SWIG_PACKAGE="${DISTDIR}"/${MY_SWIG}.tar.gz
+
+ # Needed after qtchooser removal, bug #836474.
+ -DQMAKE_QT5_COMMAND="$(qt5_get_bindir)"/qmake
+
+ -DQRENDERDOC_ENABLE_PYSIDE2=$(usex pyside2)
+ )
+
+ use pyside2 && mycmakeargs+=( -DPYTHON_CONFIG_SUFFIX=-${EPYTHON} )
+
+ # Lots of type mismatch issues.
+ filter-lto
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ docs_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "android remote contexts" dev-util/android-tools
+ optfeature "vulkan contexts" media-libs/vulkan-loader
+}