summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pngcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pngcheck')
-rw-r--r--media-gfx/pngcheck/Manifest1
-rw-r--r--media-gfx/pngcheck/metadata.xml8
-rw-r--r--media-gfx/pngcheck/pngcheck-2.3.0.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/Manifest b/media-gfx/pngcheck/Manifest
new file mode 100644
index 000000000000..73cc71e5433b
--- /dev/null
+++ b/media-gfx/pngcheck/Manifest
@@ -0,0 +1 @@
+DIST pngcheck-2.3.0.tar.gz 59864 SHA256 77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db25690f35f SHA512 d099a360d41fc553e9ea02e56ae9812a4a72f3b7f1cd73c021fdb0b9233bb247e100b95fe8e297a2dcdd1bb996128a365794cb8f5702e5c93618af03f18140ad WHIRLPOOL 21c097b90c87bfb1a7dd4324c4c8109adc4e4d1835b31bcb31ba21443ce16409947a3588619136890fb7600dab232c99903fa72c59e5e3a885230f5cd9ca6a4d
diff --git a/media-gfx/pngcheck/metadata.xml b/media-gfx/pngcheck/metadata.xml
new file mode 100644
index 000000000000..8e5a86cf66d2
--- /dev/null
+++ b/media-gfx/pngcheck/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">png-mng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/pngcheck/pngcheck-2.3.0.ebuild b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
new file mode 100644
index 000000000000..7293de435f26
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="verifies the integrity of PNG, JNG and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ CFLAGS="${LDFLAGS} ${CFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz" || die
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize} || die
+ dodoc CHANGELOG README
+}