summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-plugin-perfection-v370
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-plugin-perfection-v370')
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/Manifest2
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild94
-rw-r--r--media-gfx/iscan-plugin-perfection-v370/metadata.xml19
3 files changed, 115 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-perfection-v370/Manifest b/media-gfx/iscan-plugin-perfection-v370/Manifest
new file mode 100644
index 000000000000..34236beb08c4
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/Manifest
@@ -0,0 +1,2 @@
+DIST iscan-plugin-perfection-v370-1.0.0-2.i386.rpm 383681 SHA256 0fcd95b3c7fb5c1b26fc482513c8220d44a1cde174169e831eea9d5b04ad8537 SHA512 ca0d77e614b826529b23e7ccb6f8546143c471757fb9648c30830055764442c44c811d12c61b04e14d6d435c5de67eb20d24653aee23022ed7104ce89074fdf1 WHIRLPOOL 3b46c6b03e4a03c84348c1f6fb1ed6cdce5d8427017785d66f29f5e96d602f4ab3bc117caabe1fe309a4f8c032a3e1e7fe0091b7b008dd9b08a3b51714e03fac
+DIST iscan-plugin-perfection-v370-1.0.0-2.x86_64.rpm 172082 SHA256 072ddd22e627ee4ed8736bb8726905349bc3879c4127fcbc3b3b90f252ffd823 SHA512 d0a942f4dbf51edf773e3bd83749ffc5dc9b1b67daec042fb49b4050ead34c604ce0183b138dd0719c2fe1ba2d610034b8d2d16ba12df4cd8617d1182b66466f WHIRLPOOL f7e2a21a51589b2907ca4626cbc8dd47af338cd286c383f43ed150c3ae1871543b04faf4a6f7a3431deb767c0d5d3d18889065b353f6eef58cbcfbdad860bab1
diff --git a/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild b/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild
new file mode 100644
index 000000000000..ba6803d81669
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/iscan-plugin-perfection-v370-1.0.0.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit rpm versionator multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+SCANNER="Perfection V370"
+FIRMWARE="esfwdd.bin"
+
+DESCRIPTION="Epson ${SCANNER} and similar scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/iscan/lib/*"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}"/usr/share/iscan/*
+
+ dodoc usr/share/doc/*/*
+
+ # install scanner plugins
+ exeinto /opt/iscan/lib
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x014a /opt/iscan/lib/libiscan-plugin-perfection-v370 /usr/share/iscan/${FIRMWARE}"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file ${FIRMWARE} for ${SCANNER}"
+ elog "has been installed in /usr/share/iscan."
+ elog
+
+ # Only register scanner on new installs
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ elog "New firmware has been registered automatically."
+ elog
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ # Only unregister on on uninstall
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-perfection-v370/metadata.xml b/media-gfx/iscan-plugin-perfection-v370/metadata.xml
new file mode 100644
index 000000000000..93e07c910e9e
--- /dev/null
+++ b/media-gfx/iscan-plugin-perfection-v370/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Supports the following models:
+
+ Epson GT-F740
+ Epson GT-S640
+ Epson Perfection V37
+ Epson Perfection V370 Photo
+ </longdescription>
+</pkgmetadata>