summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-04-13 13:51:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-26 17:58:04 +0200
commit7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a (patch)
tree88d12f56b231c52c0295ac5132f6f278a13041f9 /media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
parentprofiles/arch/powerpc/package.use.mask: remove glibc[static-pie] mask (diff)
downloadgentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.tar.gz
gentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.tar.bz2
gentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.zip
media-gfx/iscan-plugin-network-nt: Version bump to 1.1.3
Closes: https://bugs.gentoo.org/711864 Signed-off-by: Marcin Deranek <marcin.deranek@slonko.net> Closes: https://github.com/gentoo/gentoo/pull/15331 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild')
-rw-r--r--media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
new file mode 100644
index 000000000000..b1b7f05ba96d
--- /dev/null
+++ b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info rpm
+
+DESCRIPTION="Network scanning plugin for EPSON scanners (nonfree)"
+
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+ISCAN_VERSION="3.62.0"
+
+SRC_URI="https://download2.ebz.epson.net/imagescanv3/centos/latest1/rpm/x64/imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/iscan"
+RESTRICT="bindist mirror strip"
+# https://bugs.gentoo.org/364129#c15
+CONFIG_CHECK="~SYN_COOKIES"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack ./imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm/plugins/imagescan-plugin-networkscan-${PV}-1epson4centos8.x86_64.rpm
+}
+
+src_install() {
+ exeinto /usr/libexec/utsushi
+ doexe usr/libexec/utsushi/networkscan
+
+ gunzip usr/share/doc/imagescan-plugin-networkscan/*.gz
+ dodoc usr/share/doc/imagescan-plugin-networkscan/*
+}