summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gtkimageview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gtkimageview')
-rw-r--r--media-gfx/gtkimageview/Manifest1
-rw-r--r--media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild78
-rw-r--r--media-gfx/gtkimageview/metadata.xml5
3 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/gtkimageview/Manifest b/media-gfx/gtkimageview/Manifest
new file mode 100644
index 000000000000..dd8af5d2110b
--- /dev/null
+++ b/media-gfx/gtkimageview/Manifest
@@ -0,0 +1 @@
+DIST gtkimageview-1.6.4.tar.gz 1158138 SHA256 4c681d38d127ee3950a29bce9aa7aa8a2abe3b4d915f7a0c88e526999c1a46f2 SHA512 6378c640006e73aa1ffbf92eb9d4e42570707bc159f0a657b11f027d328088f5e89fc334de170de5ab1a39bed588b0b76f4633688a894cb7def16f1dea9f8e39 WHIRLPOOL b623aad67b2cc3c2f6ed9bb61bf62fe75095ec3119cd0c2abd87de4d79a1d9a855f0a224e49e14f884f12a32270145233eb83f43847577b02cc536ce6212e24b
diff --git a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
new file mode 100644
index 000000000000..19d3b30f9130
--- /dev/null
+++ b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+GNOME2_LA_PUNT="yes"
+VIRTUALX_REQUIRED=test
+
+inherit autotools gnome2 virtualx
+
+DESCRIPTION="A simple image viewer widget for GTK"
+HOMEPAGE="https://projects.gnome.org/gtkimageview/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="doc examples static-libs"
+
+# tests do not work with userpriv
+RESTRICT="test? ( userpriv )"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+pkg_setup() {
+ DOCS="README"
+ G2CONF="$(use_enable static-libs static)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Prevent excessive build failures due to gcc changes
+ sed -e '/CFLAGS/s/-Werror //g' -i configure.in || die "sed 1 failed"
+
+ # Prevent excessive build failures due to glib/gtk changes
+ sed '/DEPRECATED_FLAGS/d' -i configure.in || die "sed 2 failed"
+
+ # Gold linker fix
+ sed -e '/libtest.la/s:$: -lm:g' -i tests/Makefile.am || die
+
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=${EPREFIX}/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 3 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=true" \
+ -i gtk-doc.make || die "sed 4 failed"
+ fi
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}
+
+src_test() {
+ # the tests are only built, but not run by default
+ local failed="0"
+ Xemake check
+ cd "${S}"/tests
+ for test in ./test-* ; do
+ if [[ -x ${test} ]] ; then
+ VIRTUALX_COMMAND="${test}"
+ virtualmake || failed=$((${failed}+1))
+ fi
+ done
+ [[ ${failed} -gt 0 ]] && die "${failed} tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+ if use examples ; then
+ docinto examples
+ dodoc tests/ex-*.c
+ fi
+}
diff --git a/media-gfx/gtkimageview/metadata.xml b/media-gfx/gtkimageview/metadata.xml
new file mode 100644
index 000000000000..a083c07fab9e
--- /dev/null
+++ b/media-gfx/gtkimageview/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+</pkgmetadata>