summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-06 10:34:50 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-06 13:04:30 +0200
commitdca716514f3077ecc3bba669514ec33b4731283e (patch)
tree340811c41e8a67808804a250b4f9d50eda17be1e /media-gfx/gnome-photos
parentnet-libs/webkit-gtk: bump to 2.22.7 (diff)
downloadgentoo-dca716514f3077ecc3bba669514ec33b4731283e.tar.gz
gentoo-dca716514f3077ecc3bba669514ec33b4731283e.tar.bz2
gentoo-dca716514f3077ecc3bba669514ec33b4731283e.zip
media-gfx/gnome-photos: bump to 3.28.1
Not bothering with supporting tracker-1 anymore; tracker-2 shall be stabilized soon enough and hard to check if a tracker-2 feature isn't required in gnome-photos tracker usage now. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-gfx/gnome-photos')
-rw-r--r--media-gfx/gnome-photos/Manifest1
-rw-r--r--media-gfx/gnome-photos/gnome-photos-3.28.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/gnome-photos/Manifest b/media-gfx/gnome-photos/Manifest
index 65478537b2ed..a1beb273db9c 100644
--- a/media-gfx/gnome-photos/Manifest
+++ b/media-gfx/gnome-photos/Manifest
@@ -1,2 +1,3 @@
DIST gnome-photos-3.24.6.tar.xz 986200 BLAKE2B 656737326f594958ea1cc956f85e50c7eaebc227491d95342acab9a1fa0e3c5c109efe932cd0465e48ada62beab238e6eef0e01033b145de72a1fb64ce2f3c89 SHA512 47fd858b643fe0bca9a4801d43bd7eb181db08d7e09941a60a134247df97b0e900cd062efef70da5161a9fceb1d33b998b87ad5eca0a5937a10c4e06b908de22
DIST gnome-photos-3.26.4.tar.xz 1101324 BLAKE2B 81e851bdeb39455cad6d4ba99194229507a809c3bd8c9ff0c24992cbbf90001d87f96d1c2b3c3a07101982e6ea169cba0e2249431138e962850f55fffc2c54ec SHA512 0a49b7eb29918ccf87af4211db6ffbb3c55ab40f4eaa1437317fda32de43b3b0c9033397d5b06fbc5012d0fa322a79dafdf46817cfaea57ef2f4df1a975fb489
+DIST gnome-photos-3.28.1.tar.xz 1139192 BLAKE2B c6be02cf49ef96c580759dabeeecb55d74e137a234663fe2ce78b45257abb2a0d5d52d34fdf30dd5672b054ab592f9858e9a963d593fc95dbca5c97cab2d5671 SHA512 6246c55484d45883dda93f990c52b46755420d820007a64d606685153353607a90702ac7c6e4de59c54ff9ffb5b36f15a297541c5fa866718b5ac9e44e15d35b
diff --git a/media-gfx/gnome-photos/gnome-photos-3.28.1.ebuild b/media-gfx/gnome-photos/gnome-photos-3.28.1.ebuild
new file mode 100644
index 000000000000..209f6ee527f6
--- /dev/null
+++ b/media-gfx/gnome-photos/gnome-photos-3.28.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Access, organize and share your photos on GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Photos"
+
+LICENSE="GPL-3+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flickr test upnp-av"
+
+COMMON_DEPEND="
+ >=app-misc/tracker-2.0:0/2.0
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libdazzle-3.26.0
+ gnome-base/gsettings-desktop-schemas
+ >=dev-libs/libgdata-0.15.2:0=[gnome-online-accounts]
+ media-libs/babl
+ >=media-libs/gegl-0.3.28:0.3[cairo,jpeg2k,raw]
+ media-libs/gexiv2
+ >=media-libs/grilo-0.3.0:0.3=
+ >=media-libs/libpng-1.6:0=
+ >=net-libs/gnome-online-accounts-3.8:=
+ >=net-libs/libgfbgraph-0.2.1:0.2
+ sci-geosciences/geocode-glib
+ >=x11-libs/cairo-1.14
+ >=x11-libs/gdk-pixbuf-2.32:2
+ >=x11-libs/gtk+-3.22.16:3
+"
+# gnome-online-miners is also used for google, facebook, DLNA - not only flickr
+# but out of all the grilo-plugins, only upnp-av and flickr get used, which have USE flags here,
+# so don't pull it always, but only if either USE flag is enabled
+RDEPEND="${COMMON_DEPEND}
+ net-misc/gnome-online-miners[flickr?]
+ upnp-av? ( media-plugins/grilo-plugins:0.3[upnp-av] )
+ flickr? ( media-plugins/grilo-plugins:0.3[flickr] )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+# app-text/yelp-tools needed for eautoreconf; otherwise probably just itstool
+RDEPEND="${RDEPEND}
+ >=app-misc/tracker-miners-2
+"
+
+python_check_deps() {
+ use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # XXX: how to deal with rdtscp support, x86intrin
+ gnome2_src_configure \
+ $(use_enable test dogtail)
+}
+
+src_test() {
+ virtx emake check
+}