summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 01:24:16 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 01:24:16 +0200
commit946b6aec2468bd6a96b4d1d8028496f828b6830b (patch)
treeb3ce69dbc4dd671135865a66fb8c2482a81029a8 /media-gfx/colorhug-client
parentapp-emulation/wine-staging: revert winegcc '=' parameter handling (diff)
downloadgentoo-946b6aec2468bd6a96b4d1d8028496f828b6830b.tar.gz
gentoo-946b6aec2468bd6a96b4d1d8028496f828b6830b.tar.bz2
gentoo-946b6aec2468bd6a96b4d1d8028496f828b6830b.zip
media-gfx/colorhug-client: Port to EAPI 7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/colorhug-client')
-rw-r--r--media-gfx/colorhug-client/colorhug-client-0.2.8.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/media-gfx/colorhug-client/colorhug-client-0.2.8.ebuild b/media-gfx/colorhug-client/colorhug-client-0.2.8.ebuild
index 4e4b403c6501..8113155736ce 100644
--- a/media-gfx/colorhug-client/colorhug-client-0.2.8.ebuild
+++ b/media-gfx/colorhug-client/colorhug-client-0.2.8.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-GCONF_DEBUG="no"
+EAPI=7
-inherit bash-completion-r1 eutils gnome2
+inherit bash-completion-r1 xdg
DESCRIPTION="Client tools for the ColorHug display colorimeter"
HOMEPAGE="http://www.hughski.com/"
@@ -13,8 +12,6 @@ SRC_URI="https://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
# Tests need valgrind, that needs glibc with debugging symbols
RESTRICT="test"
@@ -27,25 +24,24 @@ RDEPEND="
net-libs/libsoup:2.4
>=x11-libs/gtk+-3.11.2:3
>=x11-misc/colord-1.2.9:0=
- >=x11-libs/colord-gtk-0.1.24
-"
-DEPEND="${RDEPEND}
+ >=x11-libs/colord-gtk-0.1.24"
+DEPEND="${RDEPEND}"
+# docbook stuff needed for man pages
+BDEPEND="
app-text/docbook-sgml-dtd:4.1
app-text/docbook-sgml-utils
app-text/yelp-tools
>=dev-util/intltool-0.50
>=sys-devel/gettext-0.17
- virtual/pkgconfig
-"
-# docbook stuff needed for man pages
+ virtual/pkgconfig"
src_configure() {
# introspection checked but not needed by anything
# Install completions manually to prevent dependency on bash-completion, bug #546166
- gnome2_src_configure --disable-introspection --disable-bash-completion
+ econf --disable-introspection --disable-bash-completion
}
src_install() {
- gnome2_src_install
+ default
dobashcomp data/bash/colorhug-cmd
}