summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-10-14 09:07:49 +0200
committerSam James <sam@gentoo.org>2021-10-20 02:09:15 +0000
commit29254ca08e7ba78297245863f01589a57de198c6 (patch)
tree31079915736b9c2877c713fabce92aff315e9a49 /media-gfx/alembic
parentdev-java/bndlib: limit virtual/{jre,jdk} to 1.8 (diff)
downloadgentoo-29254ca08e7ba78297245863f01589a57de198c6.tar.gz
gentoo-29254ca08e7ba78297245863f01589a57de198c6.tar.bz2
gentoo-29254ca08e7ba78297245863f01589a57de198c6.zip
media-gfx/alembic: bump to 1.8.3
re-add building of python bindings Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/22591 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index c172695d1caa..43d77b5e5a24 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.2.tar.gz 861796 BLAKE2B 9ea2dea33b3116331dd02802055e8db7faa736bc2674e6b30209a9e178877523d9f14516b35729eaf6fc348b89367e9830ca1b998a8c7d10766b9b2f265b97d8 SHA512 23fec3d51cfd8ac8bc02749550de53a7b699ebe67654336864a8208a6a1d4f69e8e1a2c8e07832665c203788cbabbb65f346582741bac10ceb0d56c16d6b4217
+DIST alembic-1.8.3.tar.gz 862221 BLAKE2B 81639b0968dbcaac0096eac83385b7d6b1dc27b4b1652ede8cf6b6cf3aa3eea3c6f5e53f033708b61f79d99ebfaa766a9cac3345a043d6cc0ba6d6c29dcb9ed0 SHA512 0049c72d93e66e12d704d27e7ba36cd9c718667f2ce4f7baa1bee1613ed88ba53abea98f457e14f7f2144cb353810a4108d26c7dd1a1543ec2af576272f19036
diff --git a/media-gfx/alembic/alembic-1.8.3.ebuild b/media-gfx/alembic/alembic-1.8.3.ebuild
new file mode 100644
index 000000000000..c46c467c35e5
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.8.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples hdf5 python test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ >=dev-libs/imath-3.0.1[python?,${PYTHON_SINGLE_USEDEP}]
+ (
+ >=media-libs/ilmbase-2.5.5
+ python? ( >=dev-python/pyilmbase-2.5.5[${PYTHON_SINGLE_USEDEP}] )
+ )
+ )
+ hdf5? (
+ >=sci-libs/hdf5-1.10.2:=[zlib(+)]
+ >=sys-libs/zlib-1.2.11-r1
+ )
+ python? ( $(python_gen_cond_dep 'dev-libs/boost[python,${PYTHON_USEDEP}]') )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.0-0001-set-correct-libdir.patch )
+
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+
+src_prepare() {
+ cmake_src_prepare
+ # PyAlembic test doesn't properly find Imath, comment it for now
+ cmake_run_in python/PyAlembic cmake_comment_add_subdirectory Tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_BUILD_LIBS=ON
+ -DALEMBIC_SHARED_LIBS=ON
+ # currently does nothing but require doxygen
+ -DDOCS_PATH=OFF
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=OFF
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+
+ use python && mycmakeargs+=( -DPython3_EXECUTABLE=${PYTHON} )
+
+ cmake_src_configure
+}