summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 02:30:31 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:42 +0000
commit2ae130adcfd73b0f2bd27049b7949c38f472988e (patch)
tree95414c38eb1cb30394d7f99217f216fa0feee0e6 /mate-extra/mate-power-manager
parentmate-extra/mate-polkit: add 1.27.1 (diff)
downloadgentoo-2ae130adcfd73b0f2bd27049b7949c38f472988e.tar.gz
gentoo-2ae130adcfd73b0f2bd27049b7949c38f472988e.tar.bz2
gentoo-2ae130adcfd73b0f2bd27049b7949c38f472988e.zip
mate-extra/mate-power-manager: add 1.26.1, 1.27.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra/mate-power-manager')
-rw-r--r--mate-extra/mate-power-manager/Manifest2
-rw-r--r--mate-extra/mate-power-manager/mate-power-manager-1.26.1.ebuild71
-rw-r--r--mate-extra/mate-power-manager/mate-power-manager-1.27.0.ebuild71
3 files changed, 144 insertions, 0 deletions
diff --git a/mate-extra/mate-power-manager/Manifest b/mate-extra/mate-power-manager/Manifest
index f5d7cffa312c..2c1e4c25bd3a 100644
--- a/mate-extra/mate-power-manager/Manifest
+++ b/mate-extra/mate-power-manager/Manifest
@@ -1 +1,3 @@
DIST mate-power-manager-1.26.0.tar.xz 6247700 BLAKE2B 2b3cea55c4486df36a85540b842dc63d0f61df394d785f55dbbb004ab963d42fecd616d9bb8ab66d55fc04c2048dcec7d0be443ee0e753479c03b892a132fe13 SHA512 1ddede827f72738e87870d2abeed7f0767ef2e383b8325b24faa0fd1e811ed634446516e6634b19a6546ddd7185092fd757b2b2ff97f51b88a9d2c313407abd4
+DIST mate-power-manager-1.26.1.tar.xz 6266604 BLAKE2B 29800ffef3518722dda837a779a3e4cb639528a73091d905c5807adeac88d3b23978abf79fa7338bf2d7d5c7a75d99f99a144ff36c002b86f289a09f12a0a1fe SHA512 82bac7d32a94b3fa64c68973bd72b9a88b73d8368fc179ea0958e4b7d0021707394bc5dadaed23cc074e441ae4a753ba73ad5ba9030a276b87ac8b410a5fb37d
+DIST mate-power-manager-1.27.0.tar.xz 6719112 BLAKE2B 58655b356d2ee9980a4069a1270b9f53426387addd52debf90f414facca6d0f3f62d6b5fd1d2e5ced13c8a96fbe35ece300c05861653cf2d139147abffe498cf SHA512 ee397571df8582172aea571257318183d64f0298633cdd91f3d872f2db1c37c0c1ef0e5f5ad53b5eb5183265aa382dc72cdad5d7ebb02731505f81cb6611bf11
diff --git a/mate-extra/mate-power-manager/mate-power-manager-1.26.1.ebuild b/mate-extra/mate-power-manager/mate-power-manager-1.26.1.ebuild
new file mode 100644
index 000000000000..c2b566512540
--- /dev/null
+++ b/mate-extra/mate-power-manager/mate-power-manager-1.26.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Session daemon for MATE that makes it easy to manage your laptop or desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+applet +elogind keyring policykit systemd test"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+# Interactive testsuite.
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=media-libs/libcanberra-0.10:0[gtk3]
+ >=sys-apps/dbus-1
+ >=sys-power/upower-0.99.8:=
+ >=x11-apps/xrandr-1.3
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.11:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ keyring? ( >=app-crypt/libsecret-0.11 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ policykit? ( >=mate-extra/mate-polkit-1.6 )
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compile-warnings=minimum \
+ $(use_with keyring libsecret) \
+ $(use_enable applet applets) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ dbus-launch Xemake check || die "Test phase failed"
+}
diff --git a/mate-extra/mate-power-manager/mate-power-manager-1.27.0.ebuild b/mate-extra/mate-power-manager/mate-power-manager-1.27.0.ebuild
new file mode 100644
index 000000000000..c2b566512540
--- /dev/null
+++ b/mate-extra/mate-power-manager/mate-power-manager-1.27.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Session daemon for MATE that makes it easy to manage your laptop or desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+applet +elogind keyring policykit systemd test"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+# Interactive testsuite.
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=media-libs/libcanberra-0.10:0[gtk3]
+ >=sys-apps/dbus-1
+ >=sys-power/upower-0.99.8:=
+ >=x11-apps/xrandr-1.3
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.11:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ keyring? ( >=app-crypt/libsecret-0.11 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ policykit? ( >=mate-extra/mate-polkit-1.6 )
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compile-warnings=minimum \
+ $(use_with keyring libsecret) \
+ $(use_enable applet applets) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ dbus-launch Xemake check || die "Test phase failed"
+}