summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-09-03 16:41:28 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-09-25 16:31:55 -0400
commit3a911633592c4a4b39cc69509aec6ab6dab86ee0 (patch)
tree0f2015a683d55b9c19d1e917de1a1fe9623aba0d /mate-base/mate-desktop/mate-desktop-1.24.1.ebuild
parentmate-base/mate-common: Bump to 1.24.2 (diff)
downloadgentoo-3a911633592c4a4b39cc69509aec6ab6dab86ee0.tar.gz
gentoo-3a911633592c4a4b39cc69509aec6ab6dab86ee0.tar.bz2
gentoo-3a911633592c4a4b39cc69509aec6ab6dab86ee0.zip
mate-base/mate-desktop: Bump to 1.24.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-base/mate-desktop/mate-desktop-1.24.1.ebuild')
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.24.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/mate-desktop-1.24.1.ebuild b/mate-base/mate-desktop/mate-desktop-1.24.1.ebuild
new file mode 100644
index 000000000000..13b996530016
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.24.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="FDL-1.1 GPL-2+ LGPL-2+ MIT-with-advertising"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/iso-codes
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ x11-base/xorg-proto
+ >=x11-libs/gdk-pixbuf-2.36.5
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}