summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2023-01-31 15:33:01 +0100
committerEray Aslan <eras@gentoo.org>2023-01-31 15:33:21 +0100
commit01771b48e7017f27d3d31d1a153a3904546dd97c (patch)
tree979d015ef43020c418ad26f9ab8f35f1463028c0 /mail-mta
parentrocm.eclass: support RDNA3 GPU for >=5.4, remove <5 (diff)
downloadgentoo-01771b48e7017f27d3d31d1a153a3904546dd97c.tar.gz
gentoo-01771b48e7017f27d3d31d1a153a3904546dd97c.tar.bz2
gentoo-01771b48e7017f27d3d31d1a153a3904546dd97c.zip
mail-mta/postfix: add 3.8_pre20230128, drop 3.8_pre20230121
do not turn berkdb USE flag on by default anymore Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/Manifest2
-rw-r--r--mail-mta/postfix/postfix-3.8_pre20230128.ebuild (renamed from mail-mta/postfix/postfix-3.8_pre20230121.ebuild)15
2 files changed, 11 insertions, 6 deletions
diff --git a/mail-mta/postfix/Manifest b/mail-mta/postfix/Manifest
index 57d971ff62a2..3474533ed534 100644
--- a/mail-mta/postfix/Manifest
+++ b/mail-mta/postfix/Manifest
@@ -1,3 +1,3 @@
DIST postfix-3.7.3.tar.gz 4825380 BLAKE2B 005abf49b27e59bd3e3251e345df4da0c830314c4d4478aee11057163166afa1a0159017c46bead6572d29d9738a18e1a42a0b72fe260facd3ad77f8ed309271 SHA512 4ceedd1b7b364f47a3becc041cf29a48aea54e38306fd1227c5a7c25894831fb5c37150d99d781d237175e58da21ac53887c97d99bb6b715c4988777596ee890
DIST postfix-3.7.4.tar.gz 4833834 BLAKE2B edb716ef4576d339189f11b535a62f3c6f8f28613723d916f13cdd2d37228aa8768dacdb9d8616c83f0ded3a3c801c45747375ea6cfa505b668a7163c4637128 SHA512 972738291b960c90fe83861d55b1288900416167adb353418956e69bcc709a6daf84fbfde11d573eebba030654d27abc8d55f90661a2b880ccfb3a334064c236
-DIST postfix-3.8-20230121.tar.gz 4820238 BLAKE2B 0c0c0d819ad60ee8e01d14d1c1545b5a7fdaeb6a4cf0da747435a0ac7d4245d76fb4ca279ae4aca09f924bd3ef03331bc2ad399336a1b85841f5ce53ae109b97 SHA512 0dab6ec77ce1630d19cca8c8af74c0256ccb90a6bacd936ed46a4c3631d4231faf3a635f032d72f82c9bbf4a39dd6607a1fb7a9c66b27b4e3c14f4a4ee0e3569
+DIST postfix-3.8-20230128.tar.gz 4821832 BLAKE2B 28b530a260569ba69afa7dc2986de3ca1102fb39132c09530660a7fa7dbbeb4c6818ae11b5f2685be0d7d3b9be0a9ca984a19d5361b1f79c34ad5810cd2eeec4 SHA512 8a0123f02428215e21927ac35eb3799adc2cd6f25d521dfec49b8f997ea2170ab82e66737c0ffb617116847c3c955f23cc87b4bee07d7f9f9483e16fcea520fe
diff --git a/mail-mta/postfix/postfix-3.8_pre20230121.ebuild b/mail-mta/postfix/postfix-3.8_pre20230128.ebuild
index 18fb69e10d6f..67c78ad464bb 100644
--- a/mail-mta/postfix/postfix-3.8_pre20230121.ebuild
+++ b/mail-mta/postfix/postfix-3.8_pre20230128.ebuild
@@ -16,7 +16,7 @@ SRC_URI="${MY_URI}/${MY_SRC}.tar.gz"
LICENSE="|| ( IBM EPL-2.0 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="+berkdb cdb dovecot-sasl +eai ldap ldap-bind lmdb mbox memcached mysql nis pam postgres sasl selinux sqlite ssl"
+IUSE="berkdb cdb dovecot-sasl +eai ldap ldap-bind lmdb mbox memcached mysql nis pam postgres sasl selinux sqlite ssl"
DEPEND="
acct-group/postfix
@@ -53,7 +53,12 @@ RDEPEND="${DEPEND}
!mail-mta/ssmtp[mta]
selinux? ( sec-policy/selinux-postfix )"
-REQUIRED_USE="ldap-bind? ( ldap sasl )"
+# require at least one of db implementations for newalias (and postmap)
+# command to function correctly
+REQUIRED_USE="
+ || ( berkdb cdb lmdb )
+ ldap-bind? ( ldap sasl )
+ "
S="${WORKDIR}/${MY_SRC}"
@@ -141,10 +146,10 @@ src_configure() {
if ! use berkdb; then
mycc="${mycc} -DNO_DB"
# change default database type
- if use cdb; then
- mycc="${mycc} -DDEF_DB_TYPE=\\\"cdb\\\""
- elif use lmdb; then
+ if use lmdb; then
mycc="${mycc} -DDEF_DB_TYPE=\\\"lmdb\\\""
+ elif use cdb; then
+ mycc="${mycc} -DDEF_DB_TYPE=\\\"cdb\\\""
fi
fi