summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-29 22:50:09 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-31 03:39:48 +0100
commit84ca6a9211958d303a421d35c93bac1a5baaee86 (patch)
tree64b6be892cfee54c1fdced1aff825cd56891eeed /mail-filter
parentsys-fs/mp3fs: fix LICENSE, fix bug #869656 (diff)
downloadgentoo-84ca6a9211958d303a421d35c93bac1a5baaee86.tar.gz
gentoo-84ca6a9211958d303a421d35c93bac1a5baaee86.tar.bz2
gentoo-84ca6a9211958d303a421d35c93bac1a5baaee86.zip
mail-filter/zdkimfilter: fix calling ar directly, bug #893258
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/893258 Closes: https://github.com/gentoo/gentoo/pull/34550 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-3.15.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/zdkimfilter-3.15.ebuild b/mail-filter/zdkimfilter/zdkimfilter-3.15.ebuild
index 495b98b46cd9..928a0c563b2b 100644
--- a/mail-filter/zdkimfilter/zdkimfilter-3.15.ebuild
+++ b/mail-filter/zdkimfilter/zdkimfilter-3.15.ebuild
@@ -2,9 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
+inherit toolchain-funcs
+
DESCRIPTION="DKIM filter for Courier-MTA"
HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
@@ -26,6 +30,10 @@ src_configure() {
econf $(use_enable debug)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
emake DESTDIR="${D}" install
diropts -o mail -g mail