summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-04-22 08:33:56 +0200
committerFabian Groffen <grobian@gentoo.org>2022-04-22 08:34:21 +0200
commit4ad9952d876da2b83ccf9a519661afbbd5ab6d13 (patch)
tree8ee0b77f1b814034760c8edee13e59957afae8bd /mail-filter
parentdev-python/protobuf-python: Stabilize 3.19.3-r1 x86, #839717 (diff)
downloadgentoo-4ad9952d876da2b83ccf9a519661afbbd5ab6d13.tar.gz
gentoo-4ad9952d876da2b83ccf9a519661afbbd5ab6d13.tar.bz2
gentoo-4ad9952d876da2b83ccf9a519661afbbd5ab6d13.zip
mail-filter/opendmarc: stable revbump for glibc upgrade
This is clumpsy. Force update along with glibc update, such that dependent packages won't see undefined symbols due to glibc changes (resolv). Closes: https://bugs.gentoo.org/839951 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.1.1-r2.ebuild3
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.1.1-r3.ebuild71
2 files changed, 73 insertions, 1 deletions
diff --git a/mail-filter/opendmarc/opendmarc-1.4.1.1-r2.ebuild b/mail-filter/opendmarc/opendmarc-1.4.1.1-r2.ebuild
index e0c31d75209b..09be27f5139e 100644
--- a/mail-filter/opendmarc/opendmarc-1.4.1.1-r2.ebuild
+++ b/mail-filter/opendmarc/opendmarc-1.4.1.1-r2.ebuild
@@ -15,7 +15,8 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
IUSE="spf +reports static-libs"
DEPEND="reports? ( dev-perl/DBI )
- || ( mail-filter/libmilter mail-mta/sendmail )"
+ || ( mail-filter/libmilter mail-mta/sendmail )
+ elibc_glibc? ( <sys-libs/glibc-2.34 )" #839951
RDEPEND="${DEPEND}
acct-user/opendmarc
reports? (
diff --git a/mail-filter/opendmarc/opendmarc-1.4.1.1-r3.ebuild b/mail-filter/opendmarc/opendmarc-1.4.1.1-r3.ebuild
new file mode 100644
index 000000000000..c9de04f81e6b
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.4.1.1-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Open source DMARC implementation"
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="https://github.com/trusteddomainproject/OpenDMARC/archive/rel-${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3" # 1.4 has API breakage with 1.3, yet uses same soname
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="spf +reports static-libs"
+
+DEPEND="reports? ( dev-perl/DBI )
+ || ( mail-filter/libmilter mail-mta/sendmail )
+ elibc_glibc? ( >=sys-libs/glibc-2.34 )" #839951
+RDEPEND="${DEPEND}
+ acct-user/opendmarc
+ reports? (
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Message
+ dev-perl/Switch
+ )
+ spf? ( mail-filter/libspf2 )"
+
+S=${WORKDIR}/OpenDMARC-rel-${PN}-${PV//./-}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1.1-CVE-2021-34555.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ if use !reports ; then
+ sed -i -e '/^SUBDIRS =/s/reports//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with spf) \
+ $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
+ $(use_with spf spf2-lib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.la
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's:^# UserID .*$:UserID opendmarc:' \
+ -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
+ -e '/^# Socket /s:^# ::' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}