summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-13 10:13:49 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-13 10:13:49 -0500
commit5412d11adaa4a0862e6ab5228f76c6ce9484297e (patch)
tree6fa4f478ffff02ca5833f68c552af4d9032879e0 /mail-filter/policyd
parentnet-libs/miniupnpc: Bump to 2.1.20190210 (diff)
downloadgentoo-5412d11adaa4a0862e6ab5228f76c6ce9484297e.tar.gz
gentoo-5412d11adaa4a0862e6ab5228f76c6ce9484297e.tar.bz2
gentoo-5412d11adaa4a0862e6ab5228f76c6ce9484297e.zip
mail-filter/policyd: Update dependency, EAPI and make verbose
Non-maintainer commit Bug: https://bugs.gentoo.org/665916 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'mail-filter/policyd')
-rw-r--r--mail-filter/policyd/policyd-1.82-r3.ebuild (renamed from mail-filter/policyd/policyd-1.82-r2.ebuild)18
1 files changed, 11 insertions, 7 deletions
diff --git a/mail-filter/policyd/policyd-1.82-r2.ebuild b/mail-filter/policyd/policyd-1.82-r3.ebuild
index 1e145672a007..0d1be22af1b6 100644
--- a/mail-filter/policyd/policyd-1.82-r2.ebuild
+++ b/mail-filter/policyd/policyd-1.82-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Policy daemon for postfix and other MTAs"
HOMEPAGE="http://policyd.sf.net/"
@@ -14,15 +14,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="libressl"
-DEPEND="virtual/mysql
+DEPEND="dev-db/mysql-connector-c:0=
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-post182.patch"
+ "${FILESDIR}/${PN}-makefile.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-post182.patch"
- epatch "${FILESDIR}/${PN}-makefile.patch"
- sed -i -e "s/gcc/$(tc-getCC)/" Makefile
+ default
+ sed -i -e 's/@${CC}/${CC}/' -e 's/@$(CC)/$(CC)/' Makefile
ebegin "Applying config patches"
sed -i -e s:UID=0:UID=65534:g \
@@ -35,7 +39,7 @@ src_prepare() {
}
src_compile() {
- emake build || die "emake build failed"
+ emake CC=$(tc-getCC) build
}
src_install() {