summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/geary/files/geary-0.5.3-unity.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/geary/files/geary-0.5.3-unity.patch')
-rw-r--r--mail-client/geary/files/geary-0.5.3-unity.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/mail-client/geary/files/geary-0.5.3-unity.patch b/mail-client/geary/files/geary-0.5.3-unity.patch
new file mode 100644
index 000000000000..7bf282963564
--- /dev/null
+++ b/mail-client/geary/files/geary-0.5.3-unity.patch
@@ -0,0 +1,31 @@
+commit 1f875e8a629a54748eb46237fd854359aa5edbc8
+Author: hasufell <hasufell@gentoo.org>
+Date: Tue Aug 27 01:40:45 2013 +0200
+
+ provide option for unity
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 66145c9..5d4464c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,6 +28,7 @@
+ option(ICON_UPDATE "Run gtk-update-icon-cache after the install." ON)
+ option(DESKTOP_UPDATE "Run update-desktop-database after the install." ON)
+ option(DESKTOP_VALIDATE "Check generated desktop file for errors during build." ON)
++option(WITH_UNITY "Add unity support." OFF)
+
+ if (DEBUG)
+ message(STATUS "Debug build")
+@@ -46,8 +47,10 @@
+ endif ()
+
+ find_package(PkgConfig)
+-pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
+-pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
++if (WITH_UNITY)
++ pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
++ pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
++endif ()
+
+ # CMake's range-checking syntax doesn't allow for a bare less-than, so using
+ # improbably high version numbers to indicate maximum