summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 19:01:54 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:53 +0300
commit714f9a102f8a3a6b46870da6047fe0f8812e6059 (patch)
treec88a76098cda7afcd79acbf917f09b5cc37369d2 /lxqt-base/lxqt-runner
parentlxqt-base/lxqt-qtplugin: add 1.3.0 (diff)
downloadgentoo-714f9a102f8a3a6b46870da6047fe0f8812e6059.tar.gz
gentoo-714f9a102f8a3a6b46870da6047fe0f8812e6059.tar.bz2
gentoo-714f9a102f8a3a6b46870da6047fe0f8812e6059.zip
lxqt-base/lxqt-runner: add 1.3.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-runner')
-rw-r--r--lxqt-base/lxqt-runner/Manifest1
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-1.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/Manifest b/lxqt-base/lxqt-runner/Manifest
index 0156aa608d28..89fd0b81ce4e 100644
--- a/lxqt-base/lxqt-runner/Manifest
+++ b/lxqt-base/lxqt-runner/Manifest
@@ -1 +1,2 @@
DIST lxqt-runner-1.2.0.tar.xz 267912 BLAKE2B 26d0f0dd8745fe13dfe5af9e254ada68db0de0c07331a6fa2f6c2c05e9b9536528e8a3c09704d090dcbc9104381691ae1eaa77312e998245b8d189ef705052ae SHA512 098add122e4c31ed5428362c4246ea2d76e734c309c3af10dc790b84cf6aa11f5c9ff8f94680b0a35c20ce48927f323917481dc8cd2304d13c796172974b54e6
+DIST lxqt-runner-1.3.0.tar.xz 223880 BLAKE2B 2ba95d7d24bbdf656ed364c449513c65d340bc55b283ef1914244151068d99b3f67d76622286f246eeeddd4bdd09cf59fdd3ea127ce11c244a92189b16ae9203 SHA512 79351e4cebb14ce6578197dc4d4ec3ee3b5be3d3832da778b075c5e2da38dcb518113c8076a4488570e68f51cedc5a3fe4855e296e813aa2b848a386ddcd6fbc
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-1.3.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-1.3.0.ebuild
new file mode 100644
index 000000000000..e04d534c2255
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-1.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtxml-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}