summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 17:28:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 20:31:29 +0100
commit4754a0b08a458d4a80573cad1a7e12d1a83a0d48 (patch)
tree047876f68e90914376e662e63db780fe58489a22 /kde-plasma
parentkde-plasma/kscreenlocker: 5.27.11 version bump (diff)
downloadgentoo-4754a0b08a458d4a80573cad1a7e12d1a83a0d48.tar.gz
gentoo-4754a0b08a458d4a80573cad1a7e12d1a83a0d48.tar.bz2
gentoo-4754a0b08a458d4a80573cad1a7e12d1a83a0d48.zip
kde-plasma/ksshaskpass: 5.27.11 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.11.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index e572895d78fc..cfa789ed1cca 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.10.tar.xz 28044 BLAKE2B ba716a154ec0946d5e6b2dc340ce7c3dc8f84fdae52956661a4cd8aa142a977fd26bf99ea060f3834819b887ede03dca5d7d4112509384b3c1437709510e8076 SHA512 4e868547493904c79d37a9170e8d3fbce9e47ea762ae8c59507faab9517478b44cbb48cd2fa6c8bd9f9e41f74e57a859e127db258be2b7a643c6b68fecec4a31
+DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.0.1.tar.xz 28872 BLAKE2B a47391b4399c509c959c011c486622ef343eb3a48f47b79bca03d300b57bfececc386037fd56e0717296f6f1b4523c04fa03e898e7c604607d8be93de4220f32 SHA512 3b8bb17b4614fb3e850bf73a63ba5b809ffef27a8dd1e978e9ae51088a3c029311e8bd707801c465f6617f9cac1bcec8cd5972f56d4f504a58b3d4440c15206a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.11.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.11.ebuild
new file mode 100644
index 000000000000..186d46ea9339
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}