summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 21:53:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 21:55:11 +0100
commit804ff748609bc66356679400b30399ae729ca519 (patch)
tree5d0364dd6044a85f7e69133656efaf61a24926c9 /kde-misc
parentapp-emulation/wine-proton: add 7.0.5 (diff)
downloadgentoo-804ff748609bc66356679400b30399ae729ca519.tar.gz
gentoo-804ff748609bc66356679400b30399ae729ca519.tar.bz2
gentoo-804ff748609bc66356679400b30399ae729ca519.zip
kde-misc/plasma-pass: fix logging categories dir, update EAPI 7 -> 8
Add missing runtime dependency (for 1.2.0, changed upstream in git master). Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/plasma-pass/files/plasma-pass-1.2.0-fix-loggingcategories-dir.patch31
-rw-r--r--kde-misc/plasma-pass/plasma-pass-1.2.0-r1.ebuild43
2 files changed, 74 insertions, 0 deletions
diff --git a/kde-misc/plasma-pass/files/plasma-pass-1.2.0-fix-loggingcategories-dir.patch b/kde-misc/plasma-pass/files/plasma-pass-1.2.0-fix-loggingcategories-dir.patch
new file mode 100644
index 000000000000..5131f7dd54b2
--- /dev/null
+++ b/kde-misc/plasma-pass/files/plasma-pass-1.2.0-fix-loggingcategories-dir.patch
@@ -0,0 +1,31 @@
+From 5f62fcc30e7d6c8248dfb6a263ee4a49e7c19e3b Mon Sep 17 00:00:00 2001
+From: Pino Toscano <pino@kde.org>
+Date: Wed, 17 Feb 2021 21:02:08 +0100
+Subject: [PATCH] cmake: install plasma-pass.categories in newer location
+
+Install plasma-pass.categories in the proper location for it, in case
+ECM >= 5.59.0 is used.
+---
+ CMakeLists.txt | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c0bed60..c32b637 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -53,7 +53,11 @@ add_subdirectory(plugin)
+ if (BUILD_TESTING)
+ add_subdirectory(tests)
+ endif()
+-install( FILES plasma-pass.categories DESTINATION ${KDE_INSTALL_CONFDIR} )
++if(ECM_VERSION VERSION_GREATER_EQUAL 5.59)
++ install(FILES plasma-pass.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
++else()
++ install(FILES plasma-pass.categories DESTINATION ${KDE_INSTALL_CONFDIR})
++endif()
+
+ if(ECM_VERSION VERSION_GREATER_EQUAL 5.79)
+ kde_configure_git_pre_commit_hook(CHECKS CLANG_FORMAT)
+--
+GitLab
+
diff --git a/kde-misc/plasma-pass/plasma-pass-1.2.0-r1.ebuild b/kde-misc/plasma-pass/plasma-pass-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..e66dbf2a266a
--- /dev/null
+++ b/kde-misc/plasma-pass/plasma-pass-1.2.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.82.0
+QTMIN=5.15.5
+inherit ecm kde.org
+
+DESCRIPTION="Plasma applet to access password from pass"
+HOMEPAGE="https://www.dvratil.cz/2018/05/plasma-pass/ https://invent.kde.org/plasma/plasma-pass"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 ~ppc64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ sys-auth/oath-toolkit
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-loggingcategories-dir.patch
+ "${FILESDIR}"/${P}-no-werror.patch # bug 785832
+)