summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-16 19:45:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-16 19:52:14 +0100
commit74606411fb3959f7431ec164653eb203bc330435 (patch)
tree98fcf5bb89365aeb27d4fc3672432105457811dd /kde-misc
parentapp-dicts/aspell-da: add 4.2 (diff)
downloadgentoo-74606411fb3959f7431ec164653eb203bc330435.tar.gz
gentoo-74606411fb3959f7431ec164653eb203bc330435.tar.bz2
gentoo-74606411fb3959f7431ec164653eb203bc330435.zip
kde-misc/tellico: Fix version check with KF-5.100
Upstream commit 32aef89113a1939b20766bf0e09cce7287b56f40 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/files/tellico-3.4.4-fix-kf-5.100-version-check.patch25
-rw-r--r--kde-misc/tellico/tellico-3.4.4-r1.ebuild6
2 files changed, 28 insertions, 3 deletions
diff --git a/kde-misc/tellico/files/tellico-3.4.4-fix-kf-5.100-version-check.patch b/kde-misc/tellico/files/tellico-3.4.4-fix-kf-5.100-version-check.patch
new file mode 100644
index 000000000000..6cbb9aef239c
--- /dev/null
+++ b/kde-misc/tellico/files/tellico-3.4.4-fix-kf-5.100-version-check.patch
@@ -0,0 +1,25 @@
+From 32aef89113a1939b20766bf0e09cce7287b56f40 Mon Sep 17 00:00:00 2001
+From: Jonathan Esk-Riddell <jr@jriddell.org>
+Date: Fri, 21 Oct 2022 12:03:40 +0100
+Subject: [PATCH] fix version check which breaks on KF5 5.100
+
+---
+ src/newstuff/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/newstuff/CMakeLists.txt b/src/newstuff/CMakeLists.txt
+index b51914fd..c0ebfa54 100644
+--- a/src/newstuff/CMakeLists.txt
++++ b/src/newstuff/CMakeLists.txt
+@@ -19,7 +19,7 @@ TARGET_LINK_LIBRARIES(newstuff
+ )
+
+ IF( KF5NewStuff_FOUND )
+- if(${ECM_VERSION} STRGREATER "5.57.0")
++ if(${ECM_VERSION} VERSION_GREATER "5.57.0")
+ INSTALL(FILES tellico-template.knsrc tellico-script.knsrc DESTINATION ${KDE_INSTALL_KNSRCDIR})
+ else()
+ INSTALL(FILES tellico-template.knsrc tellico-script.knsrc DESTINATION ${KDE_INSTALL_CONFDIR})
+--
+GitLab
+
diff --git a/kde-misc/tellico/tellico-3.4.4-r1.ebuild b/kde-misc/tellico/tellico-3.4.4-r1.ebuild
index b05e573a3bb4..94c6dab3f550 100644
--- a/kde-misc/tellico/tellico-3.4.4-r1.ebuild
+++ b/kde-misc/tellico/tellico-3.4.4-r1.ebuild
@@ -69,9 +69,9 @@ RDEPEND="
yaz? ( >=dev-libs/yaz-2:0= )
"
DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/gettext
-"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${P}-fix-kf-5.100-version-check.patch" )
src_configure() {
local mycmakeargs=(