summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-09 12:40:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-09 16:26:58 +0200
commitc6238ecccc71a0551286dc09cb0ee0c7580ad365 (patch)
tree191b616ba5923b33d927ac59c59b95016e12309c /kde-frameworks
parentdev-java/bcmail: drop 1.69-r1 (diff)
downloadgentoo-c6238ecccc71a0551286dc09cb0ee0c7580ad365.tar.gz
gentoo-c6238ecccc71a0551286dc09cb0ee0c7580ad365.tar.bz2
gentoo-c6238ecccc71a0551286dc09cb0ee0c7580ad365.zip
kde-frameworks/frameworkintegration: 5.96.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index ddf6c1cab7b8..4a9577e71ad9 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.92.0.tar.xz 1758268 BLAKE2B 7f72908f93158f42c2e90488aa037bb7dd9146e333b504a9034c8b5c6898fb5a6357a62fc81c237f8be9b854d05c97ce4352d28aa4f28ba1674d26b0098c7e41 SHA512 3445749f4ee10493a798433a7b5630dc22701c98c3f81c7e2236cffea9f9576ce8123006e5123698e5d648771ea77bff848453b188b1a6e791aab08184cebecc
DIST frameworkintegration-5.95.0.tar.xz 1758292 BLAKE2B 54588bd57289f2b42dcadc230257d031345b0d0cbce5bf674547431b654be418e209aac2692e693e64c86175b0a08cc01ad97294cad7dfcb65c918411d47e695 SHA512 a6fbc2bdeac9a3e2aecf0b6e2bfa0169b36e02d03665758230abc2497015a1540d33e58cb0283ec8333713debb58289deb423a679f726e041ada2d325833d743
+DIST frameworkintegration-5.96.0.tar.xz 1759604 BLAKE2B 24d4806432487e35e01645da97195f700e086c68c6d2f39e7e5e86d00f10a982224fff2fa2eb7d7808fadad4d7524fd2318f67f8d47759e2533a261aa8589470 SHA512 cdc521ff7ba5d3c37d239fb7575a8c1e5b66b1bcba9e315da857b3ddd25b9a7cabc3dc0338186b23b9606badef7c7153c117b92618b626eb54b95c540cc2e680
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild
new file mode 100644
index 000000000000..e496a1e09d6c
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.4
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}