summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-24 12:35:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-24 13:09:01 +0200
commit2e07f681162a7cbc038d43de8ebba6cda4edf19a (patch)
treeb2c503b0de71d183d51708deb6e21f12846a2a58 /kde-frameworks/prison
parentdev-libs/libpfm: Stabilize 4.13.0 arm, #938444 (diff)
downloadgentoo-2e07f681162a7cbc038d43de8ebba6cda4edf19a.tar.gz
gentoo-2e07f681162a7cbc038d43de8ebba6cda4edf19a.tar.bz2
gentoo-2e07f681162a7cbc038d43de8ebba6cda4edf19a.zip
kde-frameworks/prison: Fix build w/ USE=-qml
Closes: https://bugs.gentoo.org/938343 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison')
-rw-r--r--kde-frameworks/prison/files/prison-6.5.0-cmake.patch42
-rw-r--r--kde-frameworks/prison/prison-6.5.0.ebuild2
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/prison/files/prison-6.5.0-cmake.patch b/kde-frameworks/prison/files/prison-6.5.0-cmake.patch
new file mode 100644
index 000000000000..dbd3e7c612f6
--- /dev/null
+++ b/kde-frameworks/prison/files/prison-6.5.0-cmake.patch
@@ -0,0 +1,42 @@
+From 073c611f0027ca1d7e5de18003993d3a85c2968e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 24 Aug 2024 12:31:03 +0200
+Subject: [PATCH] Fix WITH_QUICK=OFF by moving ECMQmlModule behind the
+ conditional
+
+Otherwise we still end up with
+
+> -- Could NOT find Qt6Qml (missing: Qt6Qml_DIR)
+
+and finally
+
+> Failed setting up ECMQmlModule
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6a97368..11f3a52 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,6 @@ include(ECMAddTests)
+ include(CMakePackageConfigHelpers)
+ include(ECMSetupVersion)
+ include(ECMQtDeclareLoggingCategory)
+-include(ECMQmlModule)
+ include(ECMDeprecationSettings)
+
+ set(EXCLUDE_DEPRECATED_BEFORE_AND_AT 0 CACHE STRING "Control the range of deprecated API excluded from the build [default=0].")
+@@ -39,6 +38,7 @@ option(WITH_MULTIMEDIA "Build scanner support" ON)
+ find_package(Qt6 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Core Gui)
+
+ if (WITH_QUICK)
++ include(ECMQmlModule)
+ find_package(Qt6 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Quick)
+ endif()
+
+--
+2.46.0
+
diff --git a/kde-frameworks/prison/prison-6.5.0.ebuild b/kde-frameworks/prison/prison-6.5.0.ebuild
index 873cd7cc7ee6..ac1b1b471eb0 100644
--- a/kde-frameworks/prison/prison-6.5.0.ebuild
+++ b/kde-frameworks/prison/prison-6.5.0.ebuild
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( >=dev-qt/qtbase-${QTMIN}:6[concurrent,widgets] )
"
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # bug 938343
+
src_configure() {
local mycmakeargs=(
# TODO: WITH_MULTIMEDIA?