summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-08 23:50:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-09 17:49:59 +0100
commit92ce08d47d7105b5d7a8c7140798a277b9b844ea (patch)
tree41bca5c9474de6cec35e12d8490260764da53970 /kde-frameworks/kwallet
parentkde5-functions: Raise QT_MINIMAL to 5.11.1 (diff)
downloadgentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.gz
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.bz2
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.zip
kde-frameworks: Add KDE Frameworks 5.53.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.53.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index b68ef2b046c1..4697fb3d8f95 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1 +1,2 @@
DIST kwallet-5.52.0.tar.xz 307640 BLAKE2B b42db55543198217a55185b619117583d327be5e1c022a953861dd0f67ec37bc84153a5c345256270dafaba9b40ad607ac9c33d0bab05358e1c1ade20820d3ec SHA512 63a84d0016b59297274f55eba901e0219e6c38bd6316007edda94cddd496488b4baa35c7cb38447bde70f65c35bedbe2aa5ce21b68a6a1574cf6275f62073ca6
+DIST kwallet-5.53.0.tar.xz 307664 BLAKE2B e0b58a75f9bbc7d502af5bb02429382614f626150dba81716a5b994683f84b444cf065aa28b173280c37fcb86fd7014200724c6d3911a884145fd230ab9268d2 SHA512 25d3a8d00c6b7cc3504a9dfa71aaaca1bbff63a8bac6181a1723b538061757c395b6b899ee4dae670bd458ae3621d9b5f74e7dd6c3be047325c44c5a06c8a821
diff --git a/kde-frameworks/kwallet/kwallet-5.53.0.ebuild b/kde-frameworks/kwallet/kwallet-5.53.0.ebuild
new file mode 100644
index 000000000000..44c284230462
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.53.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}