summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-10 23:00:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-11 00:03:08 +0100
commit30b0d32973fb670b8c6c7f278a0153f2ab25d178 (patch)
treecdb673bc3492e1e91ac8443d9f43b99f8a759907 /kde-frameworks/frameworkintegration
parentprofiles: Mask KDE Plasma 6 RC1 (5.92) (diff)
downloadgentoo-30b0d32973fb670b8c6c7f278a0153f2ab25d178.tar.gz
gentoo-30b0d32973fb670b8c6c7f278a0153f2ab25d178.tar.bz2
gentoo-30b0d32973fb670b8c6c7f278a0153f2ab25d178.zip
kde-frameworks/frameworkintegration: 5.248.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.248.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index a5f5f2a4cc8e..01afd37cd592 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
DIST frameworkintegration-5.247.0.tar.xz 54140 BLAKE2B 92c95d1733cff1100ea27d614b2febde6d0eaa65130e409841c6705e1d9c592fdd57cf841b38224f1406860d435172597b9b0f26107d1f255d7820e4e428a9df SHA512 890d780a12a72edb359fe76cd2323eadcedfdd9485657f126bc42c29e8defdca525df90ff36fd53041d3e74d5afd5a39c2f7e306a292b022333381ed6bcff6c3
+DIST frameworkintegration-5.248.0.tar.xz 54248 BLAKE2B 620b61128859bedc8cc2ed1aa8e0b349d93b59749ae8a2fd6f7517d9c68f6cdf3e47b7baba959a0fb30d1ae9e0c7444da9d4a9b5eabe2f4fe483fa922e258b93 SHA512 fae603dd539e522383424f72aa9deeae842ed5c6e037185d3da5292d5df6aa5c7a6694c0ed84f5cb74133918d03160cff417f525c203b7e406591b395c7eea3b
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.248.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.248.0.ebuild
new file mode 100644
index 000000000000..134bdbb27a35
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.248.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}